Registry Editor could not set security key currently selected or some of its subkeys

Adobe CS4 is driving me mad, please help.   Colour printing doesn't work, the programme installation tells me some colour profiles and settings in CS4 can't be loaded.   Have to delete a number of profiles (done) and then edit registry (HKEY_local machine/software/adobe, then PDF, Permissions.   Both administrator/everyone and system have full permission. Adobe tell
me to go under advanced,  tick 'replace all existing inheritable permissions on all descendants with inheritable permissions from this object'.   All I get is a message saying 'Registry Editor could not set security key currently selected or some of its subkeys'.   Can anyone help me solve this problem as Adobe are not exactly fast to try and help.   No earlier problems with CS2, Vista and Printer (only change is CS4).
Thanks
 

Question Info


Last updated September 17, 2018 Views 17,052 Applies to:

Hi Momco,

Since security settings for a key affect its sub keys as well, you must have permission to change security information for the key and all its sub keys in order to change security information for the key

You may check in the safe mode and let us know what happens. Safe mode is useful for troubleshooting problems with programs and drivers that might not start correctly, or that might prevent Windows from starting correctly.

i. Remove all floppy disks, CDs, and DVDs from your computer, and then restart your computer.
ii. Keep tapping the F8 key while the computer is restarting.
iii. On the Advanced Boot Options screen, use the arrow keys to highlight the safe mode option you want, and then press ENTER.
When your computer is in safe mode, you'll see the words Safe Mode in the corners of the display. To exit safe mode, restart your computer and let Windows start normally.

Check http://windowshelp.microsoft.com/Windows/en-US/help/323ef48f-7b93-4079-a48a-5c58eec904a11033.mspx  “Start your computer in safe mode”.

If the above does not work, try enabling the in-built/hidden administrator account. Then check if color printing works. If that does not work, then try changing the registry permission and check.

To enable the built-in Administrator account, follow these steps:

1. Click Start, and then type cmd in the Start Search box.
2. In the search results list, right-click Command Prompt, and then click Run as Administrator.
3. When you are prompted by User Account Control, click Continue.
4. At the command prompt, type net user administrator /active:yes, and then press ENTER.
5. Type exit, and then press ENTER.
6. Log off the current user account.

Diana
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

 


If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.