Photo Viewer puts a yellow cast over all pictures

Both in Vista 64 Ultimate and 7RC.  Other picture viewers do not do this.  Any fix?

nVidia drivers up to date, 8800GTS video card.

Question Info

Last updated June 9, 2018 Views 23,677 Applies to:

Hi RWesley,

Welcome to Microsoft Vista answers Forum!

I would like to ask few questions to help us focus in the right place.

·         How long have you been facing the issue?

·         Have you made any recent changes on the computer?

·         Was it working fine before?

I have few steps here that might fix the issue.

To solve the problem and restore normal colors in Windows Photo Gallery, you can try one of the resolutions below.

Step 1:

1. Control Panel->Hardware and Sound->Color Management.

2. Select your display device.

3. Check the box “Use my setting for this device”.

4. Click Add.

5. Choose “sRGB IEC61966-2.1” (this is the color profile that IE is using)

6. Set it as default.

If the issue still persists, go to step 2.

Step 2:

   1. Go to your desktop and right-click.

   2. Select Personalize.

   3. Select Display Settings.

   4. Click on the Advanced Settings button.

   5. Click on the Color Management Tab.

   6. Click on the Color Management button.

   7. Select your Display in the Device drop-down list.

Either of these steps should fix.

For the issues related to Windows 7, you may post your issue in this link:

If you are using Adobe Photo viewer or Adobe Image viewer, I suggest that you visit their site for further assistance.

Hope this information is helpful.
Let me know if this worked.
All the best!

Thanks and Regards:
Swathi B  - Microsoft Support.
Visit our
Microsoft Answers Feedback Forum and let us know what you think.

1 person was helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.