exe files open with adobe reader

i accidentally changed my default thing to adobe reader, how do i turn it back? all my .exe files opens with adobe reader now, System restore doesnt work(adobe reader reads it) i cant uninstall adobe reader, there is no "open with..." on any .exe file options and i tried the default programs thing in control panel and clicked on the protocol etc but i cant find .exe . i cant run any .exe file now coz adobe reader is the default. any help? thanks
 

Question Info


Last updated September 11, 2019 Views 132,440 Applies to:
Answer
Answer
I managed by going to:

default programs from the start button
associate a file type or protocol with a program
found .acrobatsecuritysettings
double clicked on it clicked on browse and found office word

it really worked

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
Hello JohnDeCastro,

Thank you for posting. 

Many times ppl face problems while opening .EXE files.

  • The EXE file opens in Notepad.
  • EXE file opens in some other installed programs.
  • Windows displays "Open With" dialog box to choose the program.
  • Windows shows error message, "Windows cannot find .exe file. Make sure you typed the name correctly".

Most of the times it happens when you accidentally change .Exe file type settings from Folder Options. Sometimes it might happen due to virus.

Anyway no need to worry. Here is a solution which will fix this annoying problem:

1. Open Command Prompt by typing command in RUN dialog box.

2. Now provide following command:

cd\windows

3. It'll activate Windows folder. Now provide following command to open Registry Editor:

regedit

4. Now goto following key:

HKEY_CLASSES_ROOT\.exe

In right-side pane, change value of Default key to exefile

5. Now goto:

HKEY_CLASSES_ROOT\exefile\shell\open\command

In right-side pane, change value of Default key to:

"%1" %*

6. Thats it. Now exit Registry Editor and restart your Windows. Now you should be able to open EXE files without any problem.


Please let me know if this helps you.


Zack


Microsoft Answers Support Engineer

24 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.