Windows Vista won't install new updates after SP2 is installed

Hi, I have a problem with updating my windows. This started after a made a factory reset. Here's the whole story:

I have a some what old laptop (8 years). It came with a factory installed Vista with service pack 1 installed. Over the years I have made a few factory resets (every 2-3 years). I've never had problems doing so till now. What happens now is that I can't move past SP2. I tried two different ways, neither of them worked. After the reset I first uninstall a bunch of stupid programs that came with the laptop, then defragment and then tried two different ways of proceeding. I tried using windows update, installed over 100 updates, kept installing updates until finally i was offered service pack 2, installed it successfully but then no more updates were offered. Then I tried a different approach - a new reset, uninstall, defragment and then downloaded and installed SP2 from the download center directly. And again the same thing happens. As soon as install SP2 I check for updates, get the new update agent and nothing happens after that. It keeps looking for new updates all day long (using ~50% of the processor all the time).

I've read quite a few articles and discussions but couldn't find anyone with the same problem (most of the users reports certain error codes which is something I can't do). I tried the Fix it tool - it doesn't do anything! Every time I run it, it finds errors - sometimes 2, other times up to 5. Sometimes it reports all of them fixed, other times it reports Missing or corrupt files not fixed. Whatever the results though I restart and when I try to check for updates again it's the same story again.

Also I tried manually installing IE9 as soon as SP2 is installed (I understand it's not supported under SP1) but the installation fails. I was expecting it to be offered in the updates but since I don't receive any updates I tried installing it myself. Not sure if it's related (though I assume it is) but Defender's not able to check for new definitions either.

Any suggestions? May be the registry is corrupt or some of the files the update agent is using are corrupt? There's currently no antivirus program installed that might be blocking anything. I haven't touched Windows Firewall in any way so everything must be set to defaults.

 

Question Info


Last updated January 23, 2020 Views 16,283 Applies to:
Answer
Answer

Did you figure this out? I ran into the exact same issue... restoring an old notebook to give to a family member, and every time I'd get to the point of installing SP2 and a newer windows update agent right after, I couldn't install anymore updates. It would hang "checking for updates" forever. Tried twice, same problem. However, I tried some things differently the third time and got past the issue.

Let me know if you still need some help and I'll reply with what I did.

451 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.