Vista Windows update hangs with "checking for updates"

Last month Vista Windows Updates started to hang with "checking for updates". 

I have: 1. Tried all fixes that I could find.
            2. Reloaded Vista with SP1 from a recovery partition.
            3. Update worked until SP2; SP2 downloaded and installed OK.

            4. Next, Update said I needed latest update agent(7.6.7600.256). It downloaded and installed  OK. At that point the Windows Update fails.
             5. If I uninstall SP2, but leave the update agent, it works. When I reinstall SP2, it fails.

             6. I installed a completely different image of Vista - this one had SP2 embedded in it. This version fails the same way.

             7. I have run SFC, CHKDSK, system diags, updated all my drivers, refreshed BIOS, and replaced the memory. As far as I can tell this is the only thing that does not work on my PC.

    Does anyone have any ideas.? -- Thanks!

 

Question Info


Last updated April 6, 2019 Views 5,071 Applies to:
Answer
Answer

Hi Ichabod22:

Thanks for feedback, and glad it worked.  I haven't had a chance to try this workaround yet - my "Checking for updates..." phase ran for 4 hours during my May 2016 Patch Tuesday update before it found 16 available updates - but quite a few Win 7 SP1 and Vista SP2 users are now reporting that pre-installing these Windows kernel-mode driver (Win32k.sys) updates each month  (e.g., KB3145739 in April 2016; KB3153199 in May 2016) reduced their Patch Tuesday updates from hours to minutes.

I doubt this will be a permanent solution so be sure to check Dalai's webpage Search for Windows Updates takes forever? - A possible solution next month to see if a new Win32k.sys update is available for download from the Microsoft Download Center before your run your June 2016 Patch Tuesday updates.

Woody Leonhard has posted a series of articles about this temporary workaround in his Woody on Windows blog, including Windows 7 update scans taking forever? KB 3153199 may solve the problem, so kudos to Woody, Dalai, and others for sharing this potential solution.

------------
32-bit Vista Home Premium SP2 * Firefox v46.0.1 * IE9 * NIS v21.7.0.11
HP Pavilion dv6835ca, Intel Core2Duo T5550 @ 1.83 GHz, 3 GB RAM, NVIDIA GeForce 8400M GS

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.