How long does it take for a system restore to run?

my computer crashed (black screen and white curser on start up)and did a systems restore - it crashed again and now the system restore has been running for more than 5 hours I was told this is because its trying to restore to a point before a Norton update (which happened when I did the earlier restart) but if it wasn't working my the morning there's a problem. Is this correct?      I'm running Vista Home Premium on a new Toshiba.
 
Question Info

Last updated August 21, 2018 Views 384,413 Applies to:
Answer

I appreciate the update.  I've never seen a System Restore take more than an hour but I suppose it is possible if the circumstances are right and especially if it's an older point where more changes were made that need to be restored.

Remember, although a System Restore can often fix such probllems, it doesn't always work.  If it doesn't work, continue with the next step in my prior post and eventually we will find the problen and/or a solutions of some kind.

Good luck!


Lorien - MCSE/MCSA/Network+/A+ --- If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

84 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

System Restore can take up to 30=45 minutes but certainly not 3 hours.  The system is frozen.  Power it down with the power button.  Also you need to dsiable Norton when doing a system rsstore because Norton interferes with the process.

Do you know when this problem began?  Try a System Restore to a point in time BEFORE the problem began.  Here's the procedure: http://www.howtogeek.com/howto/windows-vista/using-windows-vista-system-restore/.  Be sure to check the box to show more than 5 days of restore points.  If the first attempt fails, then try an earlier point or two.  NOTE: You will have to re-install any software and updates you installed between now and the restore point, but you can use Windows Update for the updates.  Use the recovery disk if the system prompt doesn’t work. The recovery disk works a bit different from the above procedures but if you follow the prompts from the System Restore menu option with the above information you should be able to restore with no problems.

If the System Restore doesn't work, do a Startup Repair by booting to the genuine Windows Vista Installation Disk (or one you can borrow from ANYONE) or from a Recovery Disk.  Here's the procedure: http://www.bleepingcomputer.com/tutorials/tutorial148.html.  To boot to the CD you may need to change the BIOS to make the CD-drive first in the boot sequence.  To do that, wait for the screen that tells you the F key to push to access the boot menu or boot setup.  Push it quickly. Make the changes, save your work, and exit.  Put the CD in the drive and reboot.  When prompted, push any key to boot from the CD.

If you don't have either disk, you can make a bootable Recovery Disk using
http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/ along with burning software like: http://www.snapfiles.com/get/active-isoburner.html and, of course, a blank CD.

If that doesn't work, try to boot into safe mode (repeatedly click the F8 key while booting and go to safe mode with networking – or do so from the command prompt on the disk).  Then let's check some of your system files:

Go to Start / All Programs / Accessories / Command prompt and right click on command prompt and click run as Administrator (you can skip this step if using the disk).

If using the disk, cd to C:\Windows\System32. Type sfc /scannow and enter and let it run.  It will scan and try to fix some of your system files.  Hopefully it will complete with no corruption it could not repair (if there is such corruption post back here or try to analyze it to find the problem file(s) using
http://support.microsoft.com/kb/928228.  Try to post any corrupted files here so we can see if they can be repaired with good copies from the installation disk (unless there are too many).

While in Command Prompt, type chkdsk /f /r and enter and let it run.  It will want to schedule itself to run at the next restart.   Answer yes and then reboot to run the program.  It will scan and try to fix any corruption or bad sectors on your hard drive and mostly remove that as a potential cause.

If that doesn't work, then please post any repeating error messages from the Event Viewer concerning startup or shutdown  (Start / Control Panel / Administrative Tools / Event Viewer – or typing eventvwr from the command prompt).  Here's how to use Event Viewer: http://www.petri.co.il/vista-event-viewer.htm.  Look in the System section.

You may be infected with malware. Try to run anti-malware programs (in safe mode with networking if necessary). To fix this problem (if it is a problem) download, install, and run the following two programs: http://www.malwarebytes.org/mbam.php and http://www.safer-networking.org/en/index.html.  You may also want to try a free trial of Pandasoft (http://www.pandasecurity.com/usa/homeusers/solutions/global-protection/).  Before downloading pandasoft, uninstall whatever anti-virus program you are currently using (because installing and running two at the same time can cause conflicts, freezes, and all sorts of problems).  Once you've uninstalled your current AV program, download, install, update, and scan using Pandasoft.  I think you might be amazed at how much it finds that the other software missed.  Once complete, uninstall pandasoft and re-install your current AV program (unless you decide to switch which I did when I first tried it about 4 years ago).  You may also want to try the new, free Microsoft Security Essentials http://www.softpedia.com/progDownload/Microsoft-Security-Essentials-Download-131683.html (with the same caveat that only ONE AV program can be installed and running on your system at any one time).  You may also want to try the free Avira at: http://www.free-av.com/ and Avast at: http://www.avast.com/index.  Reboot after completing all the scans.  You may also want to try the free OneCare at http://onecare.live.com/site/en-us/default.htm and let it run all the options (except the registry cleaner) because that’s good maintenance (it will take some time to complete but can be done in the background).

If that doesn't work, try a clean boot  http://support.microsoft.com/kb/929135.  If the problem goes away then it's just a matter of tracking down the culprit causing the problem.   Follow the procedures in the article.  Once found, delete, remove, deactivate, or uninstall it.  Once done be sure to reset Vista back to normal status as explained in the procedures. If the problem occurs in clean mode then just restore the system to normal status and reboot - this solution is not going to work.

Boot into Safe mode with networking and see if the problem occurs there.  Either result helps us narrow down the search for the cause.

Let's test your hard drive and RAM for hardware problems:

To test your hard drive, check the manufacturer and then get the diagnostic utility from: http://www.techsupportforum.com/hardware-support/hard-drive-support/302602-hard-drive-diagnostic-utilities.html (and/or get one from your hard drive or computer manufacturer if they have one available – it wouldn’t hurt to try both).  If it fails the test, replace it.  If it passes the test, then there's probably nothing wrong with it.

You can also test your RAM at http://www.memtest.org/.  If it fails, test each chip individually to find those that are bad and replace them.  If it passes, RAM is probably OK.

If that doesn't work, we'll need to do a system repair/upgrade using the genuine Windows Vista Installation Disk (one you own or one you can borrow from ANYONE).  Here's the procedure: http://www.vistax64.com/tutorials/88236-repair-install-vista.html.  Although this will not affect your data, settings, or programs, you should still backup your data before starting just to be on the safe side. You may have a lot of updates to re-install (including any service packs you had to remove).  If the version on the system came with SP1 or SP2 pre-installed and the disk is an earlier version, then you'll need to make a slipstream disk as follows: http://www.vistax64.com/tutorials/151606-vista-sp1-slipstream-installation-dvd.html.  

Hopefully one of these procedures will resolve or at least identify the cause of your problem.  If not, post back with results from what you tried and copies of some of the scans and we'll try something else.  Post back in any case so we'll know how it turned out.

Good luck!


Lorien - MCSE/MCSA/Network+/A+ --- If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

82 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.