Trying to turn on Windows firewall, getting Error code 0x6D9

I removed Webroot from my computer using uninstall window. I then began getting messages that my firewall is turned off. I tried to turn it on but kept getting the message that I was unable to open the security center error code 0x6D9. I tried to install live onecare with the same results. Yep, I tried antimalware and antispy ware to no avail.


Hi mocrew,

First I would recommend you to check if the Windows Firewall service is started and its startup type is set to Automatic. To do this, follow these steps.
1. Click Start, type services, right click on Services item from the list, click “Run as administrator”.
If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
2. From the list of services, double click on Windows Firewall, change the startup type to Automatic, click Start and then click ok.

Once the above steps are executed, check for the Firewall settings.
1. Click Start, click Control Panel.
2. Click Security Center, check if the Firewall status is ON.
3. If Firewall status is OFF, then click Windows Firewall in the left pane of the window and adjust the settings.

I would also recommend you to run “Full Service Scan” by visiting the following link.

For your reference, I’m adding some links those talk about.
1. Understanding Windows Firewall settings.
2. Turn Windows Firewall on or off.

Hope this information is helpful.
All the best!

Thanks and Regards:
Syed V - Microsoft Support.
Visit our
Microsoft Answers Feedback Forum and let us know what you think.

137 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.


Question Info

Last updated September 21, 2020 Views 229,309 Applies to: