DCOM Error 10016 - Cannot change permissions in Component Services (Vista x64)

In my Event Log I have the following:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {9BA05972-F6A8-11CF-A442-00A0C90A8F39} to the user Me-PC\Me SID (S-1-5-21-2833677475-3044246077-202295502-1000) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

So I've loaded Regedit and found CLSID 9BA05972-F6A8-11CF-A442-00A0C90A8F39 is for ShellWindows so loaded Componet Services and found ShellWindows in DCOM Config but the properties for it are all greyed out, I cannot set any security settings?

How do I resolve this issue please?

 

 

Question Info


Last updated June 9, 2019 Views 98,122 Applies to:
Answer
Answer

Hi Barry_B,    

Thanks for posting your question.   

One of the reasons the properties window of Component Services could be grayed out is because of permissions in this user account. I would suggest you try to change the permissions again in safe mode default administrator account. 

You can follow the steps in the link below to boot in safe mode

http://windowshelp.microsoft.com/Windows/en-US/help/323ef48f-7b93-4079-a48a-5c58eec904a11033.mspx  

At the login screen select the administrator account and try the same steps using Component Services. 

Note: If do not see the administrator account, follow the steps below

Enable Built-in Administrator Account:

First you’ll need to open a command prompt in administrator mode by right-clicking and choosing “Run as administrator” (or use the Ctrl+Shift+Enter shortcut from the search box)

Now type the following command:   net user administrator /active:yes

You should see a message that the command completed successfully. Log out, and you’ll now see the Administrator account as a choice.

 

If that did not work, try disabling User Account Control: 

Note: To protect your computer from other risks please enable user account control back after the troubleshooting steps are performed 

How to disable UAC

1.  Open User Accounts by clicking the Start button , clicking Control Panel, clicking User Accounts and Family Safety (or clicking User Accounts, if you are connected to a network domain), and then clicking User Accounts.
 
2.  Click Turn User Account Control on or off.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
 
3.  Select the Use User Account Control (UAC) to help protect your computer check box to turn on UAC, or clear the check box to turn off UAC, and then click OK.
 

Try again to give permissions using Component Services.

Hope this helps.  

 Regards.
Sharath Govindappa
Visit our Microsoft Answers Feedback Forumhttp://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/  and let us know what you think.

60 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.