Question

Q: Can’t access D Drive

I have two hard drives, a C drive and a D drive. The C drive contains all the important program files while the D drive contains documents, music, and games. While messing around with permissions, I accidentally locked everyone—including the administrator account—out of the D drive. This happened when I right-clicked the D drive -> properties -> security -> edit, selected “users”, and then checked the "deny" box under each setting.

After realizing I locked myself out, I tried to access the security tab again, but when I pulled up the properties window… the security tab wasn’t there. I tried doing a system restore (twice!) but it didn’t work. I also tried to fix it by allowing file sharing on the D drive, but it wouldn’t allow me to implement the changes (“An error occurred while trying to share D. Access is denied. The shared resource was not created at this time.”)

Whether I try to access the D Drive as an administrator or User, I get the same result: “D:\ is not accessible. Access is denied.”

How do I fix this?

-edit-

I don’t know if it will help, but here’s some extra information:

While I was messing with the permissions, I also locked a test folder in my C Drive (the folder was empty, but I wanted to know to what extent the permissions worked).  I right clicked it-> properties -> security -> edit, selected “users”, and then checked the "deny" box under each setting.  Then, when I realized I locked the administrator account out of the folder, I right clicked it -> properties -> security -> edit, selected “users”, and then checked the “allow” box under each setting.  It worked and I was no longer locked out of the folder.  But while that method worked with the folder, it didn’t work with the D Drive.  When I checked the properties of the D drive, there was no “security” tab.



Hi Xanira,

You may run the fix it from the article below to restore the security settings to default: “How do I restore security settings to the default settings?http://support.microsoft.com/kb/313222

Diana
Microsoft Answers Support Engineer


If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

Did this solve your problem?

Sorry this didn't help.


Thank you for your reply.

Unfortunately, the fix it didn’t work.  After I ran the fix it, was still locked out of my D Drive.  I then restarted the computer and checked again.  No luck.

 

Do I need to do something in addition to running the fix it?

Did this solve your problem?

Sorry this didn't help.


Hi Xanira,

Try restoring the security tab by following the steps below and then grant the permission.

Note: Serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: (http://windows.microsoft.com/en-US/windows-vista/Back-up-the-registry   ) How to back up and restore the registry in Windows)

1. Open the Start Menu.
2. In the white line (Start Search) area, type regedit and press Enter.
3. Click on Continue in the UAC prompt.
4. In regedit, go to:
Code:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
5. To Restore the Security Tab -
    A) In the right pane, right click on NoSecurityTab and click on Delete.
    B) Click on Yes to confirm the deletion.
    C) In regedit, go to: Code: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    D) In the right pane, right click on NoSecurityTab if it is here to and click on Delete.

    NOTE: If NoSecurityTab is not here also, then it is ok. Go to step 6.
    E) Click on Yes to confirm the deletion.
6. Close regedit.

7. Log off and log on, or restart the computer to apply the changes.

“What to know before applying permissions to a file or folder “ http://windows.microsoft.com/en-us/windows-vista/What-to-know-before-applying-permissions-to-a-file-or-folder

“Troubleshoot "access denied" when opening files or folders “ http://windows.microsoft.com/en-us/windows-vista/Troubleshoot-access-denied-when-opening-files-or-folders

Diana
Microsoft Answers Support Engineer


If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

Did this solve your problem?

Sorry this didn't help.


Hi Diana,

Thank you for your help.  I’m sorry for my late reply.

As the administrator, I opened the regedit and opened HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer  .  In the side panel, it had “ (default)”  and “NoDriveTypeAutoRun”, but no “NoSecurityTab” .

 

When I opened HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer  , the side panel had “(Default)”, “AllowLegacyWebViewer”, and “ AllowUnhashedWebViewer”, but no “NoSecurityTab”.

 

If it helps, when I try to open any folder or my C Drive, the Security Tab is still there.   The Security tab is only missing for my D Drive.  Also, all the information for my D Drive is changed.   Under Properties->General, it shows that my D Drive has a capacity of 0 bytes (it had a capacity of about 110 GB).  And it changed the D Drive’s name from “D Drive” to “Access Denied”.

Did this solve your problem?

Sorry this didn't help.


Go to Start / Control Panel / Administrative Tools / Computer Management / Drive Managment and hover your mouse over the image of D drive and a text box should appear.  Please post the EXACT contents of that text box in the order presented.  Also when you look above, does it show more accurate information about the D drive or does it still show 0 bytes?

Thanks and I await your reply.  I'm sorry to say that I do not believe it is possible to "unlock" the drive with even Administrators denied access at the root of the drive.

You can try Knoppix http://www.knopper.net/knoppix/index-en.html with a good ISO copier like: http://isorecorder.alexfeinman.com/isorecorder.htm along with a blank CD.  Boot  to this CD and see if you can access drive D using it - it just might work because it is a different operating system.  If it works, I don't think you can use it to undo the permission problem (it won't have permission either) BUT you can use it to backup the insformation/data stored on the drive in case the only option is to format the drive and thus wipe it clean of everything (and I suspect that may be the case in this situation - but there are still some options to try and more information to gather to see if there is any less drastic alternative).

I hope this helps and await your reply with the information requested.

Good luck! 

 


Lorien - MCSE/MCSA/Network+/A+ --- If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

Did this solve your problem?

Sorry this didn't help.


Thank you for your help, Lorien.  I’m sorry it took me so long to reply.

When I accessed the computer management, I did not see a Drive Manager, but there was a Disk Management.  When I hovered my mouse over my D Drive, no box appeared, but clicking on the drive highlighted one of the boxes on the bottom of the screen (bottom was in Graphical List, top was in Volume List).

Here is the top half when viewed in Volume List:

Volume: (D:)

Layout: simple

Type: Basic

File System: NTFS

Status: Healthy (Logical Drive)

Capacity: 111.79 GB

Free Space: 111.79 GB

% Free: 100%

Fault Tolerance: No

Overhead: 0%

 

Here is the top half in Disk List:

Disk: Disk1

Type: Basic

Capacity: 111.79GB

Unallocated Space: 2 MB

Status: Online

Device Type: IDE

Partition Style: MBR

 

The bottom half in Graphical List says:

(D:)

111.79 GB NTFS

Healthy (Logical Drive)

It has a light blue bar at the top of its box, which, according to the key, means “Logical drive”

 

Also, I surfed some of the other forums and tried this tip:

“ Try taking ownership of the drive from an elevated command prompt as follows:

Start>Search box>type: cmd
When cmd appears in Results above, right-click and choose "Run as administrator". A command prompt will appear. At the prompt, type:

takeown /F [foldername or drive] /r /d y [enter]
(Replace [foldername or drive] with the full path of the actual folder. Example: takeown /F D:\ /r /d y) ”

It didn’t work.  When I did this, I got the message: “ /D should be specified only with /R ”

 

Thank you again for your help, I look forward to your reply.

Did this solve your problem?

Sorry this didn't help.


Re:
[quote]
Thank you for your help, Lorien.  I’m sorry it took me so long to reply.

...

Also, I surfed some of the other forums and tried this tip:

“ Try taking ownership of the drive from an elevated command prompt as follows:

Start>Search box>type: cmd
When cmd appears in Results above, right-click and choose "Run as administrator". A command prompt will appear. At the prompt, type:

takeown /F [foldername or drive] /r /d y [enter]
(Replace [foldername or drive] with the full path of the actual folder. Example: takeown /F D:\ /r /d y) ”

It didn’t work.  When I did this, I got the message: “ /D should be specified only with /R ”


...
[unquote]

Well -- it's been several years since ANYONE posted on this topic..
All I want to know is this...

DID "you" Xanira .. ever try the obvious...
Re:
/D should be specified ONLY with (space) & not the colon backslash? Before typing /r ...

ie:
takeown /F D /r /d y)
Or was it meant to be typed as...
takeown /D /r /d y)

???
As both of those options appear to be what that "message" MEANT to state .. for that 1st incorrect code ... which generated the message that you got.???

Or have you discovered another way (into) D:/ drive ..
Or have you simply "given up in disgust" at NOT being answered by Diana D (the original Microsoft Assistant)?

Reason I am asking .. is I had an almost new Acer Aspire Z3-605 which "died" (BSOD's multiple times & several command line page messages of?
NO OPERATING SYSTEM .. via:
Please insert media and press any key to continue
...
Which of course .. totally doesn't help.

So .. having put that aside (am now able to access desktop on that machine, but ALL original files and SOME (not all) of the six user accounts are saved deep inside D:/ drive, NONE of which can be "restored" to the NEW USER ACCOUNT in C:/ drive that a "local" so-called expert created .. when he attempted to "fix" the BSoD's...

I can access the D:/ drive but can NOT restore any of the original user accounts..
Nor can I figure out HOW to do that - by copying those user files to any of the NEW USER C:/ drive folders..

QUIX _tm_ - NZ

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


I have windows 10 and I need to know how to access Drive D to be able to launch a DVD video
Dexter William Edward Larose

Did this solve your problem?

Sorry this didn't help.


 
Question Info

Views: 19,126 Last updated: July 18, 2018 Applies to: