Access Denied on Local Disk D

SOMEBODY PLEASE HELP ME!!!!! I need help changing permissions and taking ownership of my Local Disk D.I have denied all permissions to my Windows Vista Local Disk D,and now I cannot change the permissions or take ownership even as an Administrator.System Restore didn't help.The disk is marked "Access Denied" and when you go to its properties,you find the following: General: Access Denied All spaces 0 bytes Sharing: Not Shared Security: Current owner---Unable to display current owner When I click to change ownership to Administrator,I get "Unable to set new owner on Access Denied (D:). Access is Denied" Same results when I go to Advanced. Please help me!!!.I don't want to lose my documents on the Disk.
 

Question Info


Last updated November 8, 2019 Views 72,543 Applies to:
Answer
Answer
Apologies for necroposting, but I just want to say that this absolutely saved my life!

To elaborate a bit and make it a tiny bit clearer:
if you have ever shared the folder/file in question, go to your task manager, and go to your 'services'.
Right click on "WMPNetworkSvc" and stop the service (this will take a few seconds).
Attempt to delete the file, if it doesn't work, try looking in the descriptions and stop any process that has the word 'sharing' in it.
Make sure to reenable the services once the file has been deleted!

Really hope this helps.
Matt

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
How did this happen? What were you trying to accomplish?

Try taking ownership of the drive from an elevated command prompt as follows:

Start>Search box>type: cmd
When cmd appears in Results above, right-click and choose "Run as administrator". A command prompt will appear. At the prompt, type:

takeown /F [foldername or drive] /r /d y [enter]
(Replace [foldername or drive] with the full path of the actual folder. Example: takeown /F D:\ /r /d y)

If the operation was successful, you should see:

"SUCCESS: The file (or folder or drive): "filename" now owned by user "Computer Name\User name"."

Then to assign the Administrators group Full Control Permissions for the folder, use this syntax:

icacls [foldername] /grant administrators:F /T [enter]

The /T parameter is added so that the operating is carried out through all the subdirectories and files within that folder.

If that doesn't help, boot the system with a Linux Live CD such as Knoppix and copy the data on the drive to a USB thumb drive or external hard drive (or burn to CD/DVD-R - not RW). Linux will not honor Windows' permissions. Then once the data is safe you can format the drive and start over with it.

MS-MVP - Elephant Boy Computers - Don't Panic!
Elephant Boy Computers - Don't Panic!

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.