windows xp automatic camera detection

Hey,
I have Windows XP Professional, and an Olympus Stylus Tough-3000 digital camera. It works on my Windows 7 computer, but when I plug it in my XP computer, all I hear is the sound, and then a box comes up that says "choose which program to use with your device." There are none listed, so I downloaded Picasa 3, but it won't work. And when I go to Scanners and Cameras then plug in my camera, the icon for my camera shows up briefly, then disappears. PLEASE HELP!
Answer
Answer
Maybe something in the following collection of suggestions (previously posted
in the MS newsgroups)  will shed some light.

Before you connect your camera to your computer, make sure you have enough
battery power or better yet use your AC connector if your camera came with
one. Then, check your camera manual.  With most cameras you simply power
them on and set them to take pictures, with some you need to set them to
something like connect to PC or set PTP. After connecting, power the camera
and wait about 15-20 seconds for XP to recognize the camera, you will hear
some sound "ding-dong" and the LCD screen on your camera will change (the
change is dependent on the type of camera you have) and you are now ready to
transfer, even if the Autoplay window does not open automatically.  If you
do not hear a sound or the LCD screen of your camera does not change, the
connection with the USB port is not correct. Go to the bottom of these
directions to repair the USB connection.
 
After you hear the sound:
 
1. Open My Computer, look under devices with removable storage. Your camera
(or card reader) will be listed there as an external drive (probably listed
below your CD drive). Right click on your camera listed as an external
drive. A menu will open, click on Autoplay listed on the opening menu. This
should open the Autoplay window to download your photos the same way as when
the Autoplay window opens automatically when you connect your camera.
 
Or
 
2. Open My Computer, look under devices with removable storage. Your camera
will be listed there as an external drive (probably listed below your CD
drive). Double click on it to open it.
You will see a folder, double click to open it, then another folder, double
click on it to open it and you will see the list of photo files. Select all
files and copy to a folder on your hard drive. To select all the files, hold the
Ctrl key down and press the letter A. Or, click on Edit on your top bar and
then click on Select all on the opening menu. When files are selected, their
names are highlighted in blue.   You can then look at the menu on the left
of the file names and click on Copy and then select the folder you want or
make a new folder.

If you want to repair the automatic Autoplay window you can try the
following.

Different ways to try to repair the Autoplay window for downloading from
either a camera or card reader. Also the same procedure can be used for a CD
drive Autoplay.

Go from steps I to V, although step V may not be needed.

I. Connect your camera (or card reader) to your computer, and make sure you
have pictures on your memory card. Make sure your batteries are good or better
yet, use your AC adapter if your camera came with one. If you are trying
with a card reader, just connect it with a memory card inserted and with
pictures on the memory card. Power the camera on, wait 10-15 seconds for XP
to recognize it, you should hear a sound and the LCD screen of your camera
will change, the change is dependent on the type of camera you have.

Click on My Computer and look under Device with Removable storage. Your
camera will be listed there, probably below your CD drive, and a drive
letter will be assigned to it (something like H, G, etc.) You will use this
drive letter in a step below, so just note down what the drive letter is.
If you do not see your camera listed there you will need to repair your USB
connection (see below for repair) or you are on a network and the network
drive is Z and XP cannot assign a drive letter to your camera. You will need
to take care of this first. The steps below will not work if XP cannot assign
a drive letter for your camera. In some cases, your camera may be listed
but with no drive letter. Try the drive letter after the CD or DVD drive under
which your camera is listed.

II. Click on Start, click on Run and type the following in the textbox:
REGSVR32 SHIMGVW.DLL
and press Enter
Note that there is a space between ...32 and SHI...
This will take a few seconds to run.

III.  Download the autofix.exe file from the site below.  At this Microsoft
site, you have the option of downloading the autofix.exe file in one of your
folder (or make a new folder and save the file there), then open the folder
and double click on the file and then follow directions on the screen. Or,
let Microsoft scan your computer to make the repair. You will need your
camera drive letter during this step.  After this, reboot your computer.
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en
 
IV. After rebooting, power the camera on, wait 10-15 seconds for XP to
recognize it, you should hear some beeping sound and the Autoplay window
should now open giving you the option of downloading photos from the camera.

V. You may have to set the options for this window.
Click on My Computer, your camera should be listed there under Devices with
Removable Storage. Right click on it and click on Properties. In the opening
window, click on the Autoplay tab and under Select, scroll to Pictures to
select it. Select the button Prompt me...  Do the same thing for a CD drive.
 
Another solution posted by Bill, using a Nikon camera.

I installed the camera via the control panel add hardware function. It went
to a point of requiring a file called ptspusd.dll from service pack one. I
found the file via search on my hard drive. Typed the path in the window
that asked for it and it took. Solved the problem. Check your set up menu on
the camera to see your USB setting is PTP
 
To repair your USB connection:

Go to Control panel>Performance and maintenance>System>Hardware>Device
manager>Universal Serial Bus Controller, click on the + sign to see the list
of installed devices. If your camera is connected, it should be listed there
with a yellow flag (the yellow flag indicates that although the connection
is there, it is not working properly).

Right click on it>Properties>Troubleshoot. See if the troubleshooter can
help. If not, click on Action on the top bar and then Uninstall. Leave your
camera on and connected and reboot. XP should now recognize the camera and
install it (I am assuming here that your camera is fully compatible with XP
and according to your manual you do not need to install a driver, this
should be true for cameras of 2001 and up).
 
Also, check the software you use for photo editing. When you open the
software, click on File on the top bar. Look at the opening menu. You
probably have an option for downloading photos from a camera or scanner or
card reader.
 
Something else may be the problem (This is a more recent, June 2004,
problem) as reported here:

There are a lot of messages here about the camera wizard suddenly not
working. Same for me after having it work for at least a year. One of the
messages mentioned upgrading Real Player seemed to cause the problem. I
recently upgraded that also. Just uninstalled it and my camera wizard came
back immediately - this after weeks of trying to figure out what went wrong!
--
Brigit
 
(Note: some have reported that uninstalling Real Player 10 works fine,
others have reported that they had to use the autofix.exe after removing
Real Player 10. Real Player is aware of the problem and working on a fix).
Apparently there was no problem with Real Player 9.

Another possible solution.

Click on Start, click on Run and type the following in the opening textbox:

cmd

and press the Enter key

A window will open (black and white) and will display the following:

C:\Documents and Settings\Your Name\

Type the following at the end of the above line after the \

Net start stisvc

And press the Enter key

You will get a message that service is already started (if so this does not
solve the problem) or that it is starting (if so this may solve the
problem). Then try connecting your camera after you close this window. To
close this window, type EXIT at the end of the displayed line and press the
Enter key.

More info posted in the newsgroup:

SOLVED IT! Open Tweak UI if you have it. Get it if you
don't. In Tweak UI, open the My Computer tab/line and
click on Drives. A list of all possible drive names will
appear with the ones you want to show in My Computer
checked. If your removable storage/generic volume/camera
drive as shown in Device Manager (mine was F:) is not
checked, check it. The drive will appear in My Computer.
If your drive is already checked, it's something else.

Tweak UI can be downloaded from the following site:

Windows XP PowerToys /
free download
http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx
.......Volunteer J - MS-MVP......
.....This Is Not Tech Support....
***Proceed at your own risk***

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 6, 2018 Views 2,162 Applies to: