Windows Media Player cannot play DVD video. You might need to adjust your Windows display settings. Open display settings in Control Panel, and then try lowering your screen resolution and color quality settings.

I have recently encountered a problem viewing DVDs on my PC.  The above is what it is saying and I have tried to change the settings of my screen resolution and it still won't play DVD's.  Why all of the sudden am I having this problem?

Hi LoriMc,

1. Were you able to play the same DVD earlier?
2. Does it happen with a particular DVD or all of them?
3. Do you have third party DVD decoder software installed on your computer?

Step 1:
Try running Windows Media Player DVD troubleshooter and check if it helps:
a. Open the Windows Media Player DVD troubleshooter by clicking the Start button, and then clicking Control Panel.
b. In the search box, type troubleshooter, and then click

Troubleshooting. Click View all, and then click Windows Media Player DVD:

Play a CD or DVD in Windows Media Player:

Step 2:
Try updating the codecs to check if the issue persists. Also uninstall if you have any third party CD\DVD burning software installed.

Refer the below mentioned Windows help article.
Codecs: frequently asked questions:

Step 3:

I would also suggest you to update the latest drivers for your display adapter from the manufacturer’s website and then check for the issue.

a. Open Device Manager by clicking on Start, then type Device Manager.‌
b. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
c. Look for the Display adapter drivers, right click on it and select ‘Update Driver’.
d. Once the drivers are installed, boot the computer and check for the issue.

Update drivers: recommended links:

Step 4:
Try reducing the Hardware Acceleration.

a. Open Screen Resolution by clicking the Start button, clicking Control Panel, and then, under  Appearance and Personalization, clicking Adjust screen resolution.
b. Click Advanced settings,Troubleshoot tab, and then click  Change settings.
c. Move the Hardware acceleration slider toward None to reduce or turn off video hardware acceleration.
d. Click OK, and then click Restart Now

Manasa P – Microsoft Support.

4 people found this reply helpful

Was this reply helpful?


Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated September 13, 2021 Views 25,362 Applies to: