MMC broken, how to reinstall

Platform Vista x64 Business, Remote Server admin tools installed. Network management workstation.
First, a few weeks ago the 32 bit version of MMC cratered - most all of the Administrative tools  I tried to run gave an error. Now it is worse, I was testing EventTracker Pulse yesterday and I could no longer run Event Viewer and of course Task Scheduler. The services were running, but I get this error:

Description:
  Stopped working

Problem signature:
  Problem Event Name: CLR20r3
  Problem Signature 01: mmc.exe
  Problem Signature 02: 6.0.6001.18000
  Problem Signature 03: 47919524
  Problem Signature 04: MMCEx
  Problem Signature 05: 3.0.0.0
  Problem Signature 06: 4791a6e6
  Problem Signature 07: 81f
  Problem Signature 08: 77
  Problem Signature 09: N3CTRYE2KN3C34SGL4ZQYRBFTE4M13NB
  OS Version: 6.0.6001.2.1.0.256.6
  Locale ID: 1033

It appears that it is probably a permissions error of some sort. I was able to remote into a server running Window 2008 x64 and remote-manage to get a peek at the event logs. Nothing appears in the Application log, but the Security log gives an audit failure:

A handle to an object was requested.

Subject:
 Security ID:  domain\id
 Account Name:  id
 Account Domain:  domain
 Logon ID:  0x942ed

Object:
 Object Server:  Security
 Object Type:  File
 Object Name:  C:\Windows\System32\eventvwr.msc
 Handle ID:  0x0

Process Information:
 Process ID:  0x155c
 Process Name:  C:\Windows\System32\mmc.exe

Access Request Information:
 Transaction ID:  {00000000-0000-0000-0000-000000000000}
 Accesses:  READ_CONTROL
   SYNCHRONIZE
   WriteData (or AddFile)
   AppendData (or AddSubdirectory or CreatePipeInstance)
   WriteEA
   ReadAttributes
   WriteAttributes
   
 Access Mask:  0x120196
 Privileges Used for Access Check: -
 Restricted SID Count: 0

I tried running regedit as Administrator and resetting the rights for administrators to replace all existing ineritable permissions on all decendants with interitable permissionsfrom this object to overwrite the settings with the inherited ones, but got the message "Registry Editor could not set security in the key currently selected or some ot its subkeys."

So I tried using the Resource Kit tools like this:
subinacl /subkeyreg HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns /grant=administrators=f /grant=system=f

It reset the rights, but I still can't open eventvwr.msc, even running mms as administrator and running it from there.

I have put a huge amount of time and effort into setting up this workstation as I have it now. I hate to have to reinstall again.

Anyone have any ideas before I burn it down and start over?


SnoBoy
 

Question Info


Last updated September 5, 2019 Views 14,080 Applies to:
Answer
Answer
Hi SnoBoy, 

Thank you for visiting the Microsoft Windows Vista Community site. The issue you posted is related to Server admin tools and would be better suited in the TechNet community. Please visit the link below to find a community that will offer the support you request..

http://social.technet.microsoft.com/Forums/en-US/category/windowsvistaitpro/
Shane
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Shane

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.