internet time sync error

When trying to update the internet time I get a message like A'n error occured while windows was synchronizing with.....' regardless of the time server used.

I tried using the command w32tm /resync as an administrator but it said 'the computer did not resync because no time data was available'.

This update problem occurred after my laptop suddenly shut down once. Ever since I restarted, I have been facing this problem. 

 

 

Question Info


Last updated April 14, 2019 Views 11,365 Applies to:
Answer
Answer

Do you know when this problem began?  Try a System Restore to a point in timeBEFORE the problem began.  Here's the procedure: http://www.howtogeek.com/howto/windows-vista/using-windows-vista-system-restore/.  Be sure to check the box to show more than 5 days of restore points.  If the first attempt fails, then try an earlier point or two.  NOTE: You will have to re-install any software and updates you installed between now and the restore point, but you can use Windows Update for the updates.  Use the recovery disk if the system prompt doesn’t work. The recovery disk works a bit different from the above procedures but if you follow the prompts from the System Restore menu option with the above information you should be able to restore with no problems.

If the System Restore doesn't work, do a Startup Repair by booting to the genuine Windows Vista Installation Disk (or one you can borrow from ANYONE) or from a Recovery Disk.  Here's the procedure: http://www.bleepingcomputer.com/tutorials/tutorial148.html.  To boot to the CD you may need to change the BIOS to make the CD-drive first in the boot sequence.  To do that, wait for the screen that tells you the F key to push to access the boot menu or boot setup.  Push it quickly. Make the changes, save your work, and exit.  Put the CD in the drive and reboot.  When prompted, push any key to boot from the CD.

If you don't have either disk, you can make a bootable Recovery Disk using
http://neosmart.net/blog/2008/windows-vista-recovery-disc-download/ along with burning software like: http://www.snapfiles.com/get/active-isoburner.html and, of course, a blank CD (perhaps made on a different computer).

If that doesn't work, try to boot into safe mode (repeatedly click the F8 key while booting and go to safe mode with networking – or do so from the command prompt on the disk).  Then let's check some of your system files:

Go to Start / All Programs / Accessories / Command prompt and right click on command prompt and click run as Administrator (you can skip this step if using the disk).

If using the disk, cd to C:\Windows\System32. Type sfc /scannow and enter and let it run.  It will scan and try to fix some of your system files.  Hopefully it will complete with no corruption it could not repair (if there is such corruption post back here or try to analyze it to find the problem file(s) using
http://support.microsoft.com/kb/928228.  Try to post any corrupted files here so we can see if they can be repaired with good copies from the installation disk (unless there are too many).

While in Command Prompt, type chkdsk /f /r and enter and let it run.  It will want to schedule itself to run at the next restart.   Answer yes and then reboot to run the program.  It will scan and try to fix any corruption or bad sectors on your hard drive and mostly remove that as a potential cause.

If that doesn't work, then please post any error messages from the Event Viewer concerning time (Start / Control Panel / Administrative Tools / Event Viewer).  Here's how to use Event Viewer: http://www.petri.co.il/vista-event-viewer.htm.  Look in the System section.  I KNOW there will be errors there.  Please click on one for more details, copy them, and post them here in your reply.

You may be infected with malware. Try to run anti-malware programs (in safe mode with networking ifnecessary). To fix this problem (if it is a problem) download, install, and run the following two programs:http://www.malwarebytes.org/mbam.php andhttp://www.safer-networking.org/en/index.html.  You may also want to try a free trial of Pandasoft (http://www.pandasecurity.com/usa/homeusers/solutions/global-protection/).  Before downloading pandasoft, uninstall whatever anti-virus program you are currently using (because installing and running two at the same time can cause conflicts, freezes, and all sorts of problems).  Once you've uninstalled your current AV program, download, install, update, and scan using Pandasoft.  I think you might be amazed at how much it finds that the other software missed.  Once complete, uninstall pandasoft and re-install your current AV program (unless you decide to switch which I did when I first tried it about 4 years ago).  You may also want to try the new, free Microsoft Security Essentialshttp://www.softpedia.com/progDownload/Microsoft-Security-Essentials-Download-131683.html (with the same caveat that only ONE AV program can be installed and running on your system at any one time).  You may also want to try the free Avira at:http://www.free-av.com/ and Avast at: http://www.avast.com/index.  Reboot after completing all the scans.  You may also want to try the free OneCare athttp://onecare.live.com/site/en-us/default.htm and let it run all the options (except the registry cleaner) because that’s good maintenance (it will take some time to complete but can be done in the background).

If that doesn't work, try a clean boot http://support.microsoft.com/kb/929135.  If the problem goes away then it's just a matter of tracking down the culprit causing the problem.   Follow the procedures in the article.  Once found, delete, remove, deactivate, or uninstall it.  Once done be sure to reset Vista back to normal status as explained in the procedures. If the problem occurs in clean mode then just restore the system to normal status and reboot - this solution is not going to work.

If that doesn't work, we'll need to do a system repair/upgrade using the genuine Windows Vista Installation Disk (one you own or one you can borrow from ANYONE).  To do this you have to also be able to boot normally.  Here's the procedure:http://www.vistax64.com/tutorials/88236-repair-install-vista.html.  Although this will not affect your data, settings, or programs, you should still backup your data before starting just to be on the safe side. You may have a lot of updates to re-install (including any service packs you had to remove).  If the version on the system came with SP1 or SP2 pre-installed and the disk is an earlier version, then you'll need to make a slipstream disk as follows:http://www.vistax64.com/tutorials/151606-vista-sp1-slipstream-installation-dvd.html.  Please reply before doing the next step as it is a radical option and I’d like to make sure we’ve ruled out all other options before taking that step.

If that doesn't work (or you don’t have the disk), then I'm afraid the only option is a clean install.  You can use Knoppixhttp://www.knopper.net/knoppix/index-en.html with a good ISO copier like: http://isorecorder.alexfeinman.com/isorecorder.htm along with a blank CD.  This should give you enough access to the system (if you can't get in any other way) to backup your important data.  Once done, you can do a clean install either using the genuine Windows Vista Installation Disk or the Recovery Disk or the Recovery Partition (whatever process is dictated by your computer manufacturer – you may need to contact them for the procedure and perhaps to get recovery disks).  To do a clean install proceed as follows:http://www.winsupersite.com/showcase/winvista_install_03.asp (adapted as necessary by the procedures of your computer manufacturer).  Then you will need to re-install all your programs, reset all your preferences, reconfigure your network and email settings, restore your backed up data, run Windows Update with possibly nearly 100 updates pending,...

Hopefully one of these procedures will resolve or at least identify the cause of your problem. 

Good luck!
Lorien - MCSE/MCSA/Network+/A+ --- If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.