Intel X25M SSD: Slow boot time in Vista64

Just installed my Intel X25-M G2 80gb SSD as boot drive in my machine with a fresh install of Vista Home Premium 64, and while it's very snappy with applications, I'm disappointed in the Vista load time itself. From power on to "Windows loading" takes ~14 seconds, then another 23 seconds to desktop, approximately the same time it took to load on my conventional 7200rpm drive. Changing AHCI/IDE doesn't make much of a difference. Nothing in startup folder, this is basically a clean install with no apps other than Firefox.

Why isn't the SSD dramatically faster?

The hangup appears to be my old boot drive, now drive D (Hitachi 1TB 7200rpm), which I hear grinding away while Vista is loading from the SSD boot drive. I also hear it grinding away several times after I get to desktop despite never explicitly accessing any files/apps on it. Drive D is not indexed, write caching enabled, advanced performance enabled. Shows up as D/Simple/Basic/NTFS/Status: Healthy (Active, Primary Partition). All the Boot/Page File/Crash Dump is on the SSD C drive. I do have Vista installed on the D drive as well, but the BIOS is definitely booting straight to the SSD, and there's no boot menu ever offered.

If I disable the 7200rpm drive in device manager , my Windows load time is cut by 10-12 seconds.

Why does Vista insist on accessing my secondary drive, and is there any way to optimize this especially during the O/S loading?
 

Question Info


Last updated March 25, 2018 Views 4,727 Applies to:
Answer
Answer
Does adding 10s to the boot seem excessive for a secondary drive?


What's funny is if I disable the 7200rpm drive in device manager, on my next boot I'll get the faster boot, and then if I go to activate it in device manager the hard drive is available almost instantly with no delay which seems much more efficient than whatever it's doing during the boot process.
Hi,

this is something i can't anwser. I may be a driver issue or a HDD firmware issue.

You can use devcon.exe to enable/disable the device:

http://support.microsoft.com/kb/311272

Because it needs elevated rights, create two scheduled tasks and run them from command line to avoid the UAC prompt. To do this folloy my guide here:

http://www.msfn.org/board/faq-uac-part2-t135472.html

André

"A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.