How to enable DEP options mine are grey and i cant add programs to ignore.

I am signed in as admin
 

Question Info


Last updated November 7, 2018 Views 36,005 Applies to:

Hi jjstevenson85

Thank you for using Microsoft Answers Forums!

Are you logged in as the Administrator? Try to login as the Administrator and then check if DEP is still grayed out.  

You may follow the below mentioned steps to set the Default Administrator account.

1. Click the Start button

2. From the Start Menu, Click All programs followed by Accessories

3. In the Accessories menu, Right Click on the Command Prompt option

4. From the drop down menu that appears, Click on the 'Run as administrator' option

5. If you have the User Account Control (UAC) enabled, you will be asked for authorization prior to the command prompt opening. You may simply need to press the Continue button if you are the administrator or insert the administrator password etc.

6. In the Command Prompt window, type the command net user administrator /active:yes and press Enter.

7. Close the elevated command prompt.

8. Log off (in Start Menu) and you will see your new built-in Administrator account next to your current account(s).

9. Click on the icon for Administrator account to log on to it and check if DEP is grayed out or not.

If DEP is not grayed out then try these steps:

To Turn DEP on or off for a Particular Program try these steps:

1. Open the Control Panel. (Classic View)

A) Click on the System icon.

B) Go to step 3.

OR

2. Open the Start menu.

A) Right click on Computer and click Properties.

3. Click on Advanced system settings. (In upper left green area)

4. Click on the Continue button in the UAC prompt.

5. Click on the Settings button under Performance section.

6. Click on the Data Execution Prevention tab.

7. Turn DEP On for Essential Windows Vista Programs and Services Only -

NOTE: This turns on DEP for only the 32 bit system programs and services. This is the default setting.

A) Dot Turn on DEP for essential Windows programs and services only.

B) Go to step 9.

8. Turn DEP On for All Programs and Services Except for the Ones you select -

NOTE: This turns on DEP for every 32 bit program except for the ones that you add to the list. The listed program will have DEP turned off for it.

A) Dot Turn on DEP for all programs and services except those I select.

B) Click Add to add the programs (32 bit) that you do not want to use the DEP feature.

C) Navigate to the program's .exe file that you want to add to the DEP exclusion list and    select it, and then click on Open.

9. Click on OK to apply.

10. Restart the computer to apply changes.

If DEP is grayed out then try this:

When enabling:

            bcdedit.exe /set {current} nx AlwaysOn 
            bcdedit.exe /set {current} nx optin

When disabling:

            bcdedit.exe /set {current} nx AlwaysOff

Refer to: http://social.technet.microsoft.com/Forums/en-US/itprovistasecurity/thread/b03a0e1a-85a5-4bb3-b8f4-1eab23a0fe6d/

Also refer to this link for More Information:

http://windows.microsoft.com/en-US/windows-vista/Data-Execution-Prevention-frequently-asked-questions


Post back and let us know if this has helped to resolve your issue.

All the best!

 

Thanks and Regards,

Uma R    - Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I added the admin account as directed but the options are still greyed out i appreciate your time and any othe suggestions would be helpful

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

same here, they are still grayed our for me, i hate you DEP...

79 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 

Hi,

Thank you for contacting the Microsoft Community.

I would have you create a new thread of your own to avoid confusion and get a better exposure.

Refer the link-

http://answers.microsoft.com/en-us

Do get back to us for any issues pertaining to Windows in the future. We will be happy to help.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there a way to turn off DEP for a specific program via the command line options? Or does the command line turn off Everything only?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

can you help i've tried all options above please

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 i also have that prob :(
RSD

74 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.