an error occurred while windows was synchronizing with time.windows.com

My time synchronization utility is turned on. I cannot synchronize time with any time server-I have tried 5 or 6 different ones.  I shut off my firewall/antivirus program, but no help. I get the error message quoted above. It seems like it takes a lot of time before the error message comes up. Perhaps something is timing out?
 

Question Info


Last updated November 13, 2018 Views 115,413 Applies to:
Answer

Rob,

 

I tried the recommended 3rd party app, and finally found one server that worked (some others did not, and I got error messages). But to make the server work,  I had to go into my McAfee firewall and give this program permission for outgoing access to the internet.

 

The  error messages from my unsuccessful attempts to sync the clock with the program mentioned the need to give the program access to Port 123. As far as I know, I did not do this. Instead I only gave the program permission for outgoing internet access under my McAfee firewall settings.

 

Is it safe to give this program "outgoing access" to the internet?  I do not know what the program does to port 123 once it is given permission foroutgoing access to the internet... Some sources say that messing with Port 123 is not secure. I have no clue. 

 

Thanks!

98 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.