Windows 7 multiple networks on startup

Hi all, having an uissue with an otherwise GREAT OS being every time I start my pc, I can't connect to the net because it's showing as being connected to multiple networks.

I have;
A wireless modem router with 4 ports
A laptop running Vista that connects wirelessly with no issues
A pc with no wireless card connected with ethernet cable. This is where the issue is. EVERY time I start the pc up, it can't connect to the internet because there are multiple networks. A Home network and an Unidentified network.

I can disable the network adapter, enable it and the pc will then only connect to the Home network and no issues with the net. I have tried deleting the network  as per other threads and rebooting the pc. This seems to works once then the multiple networks issue reappears.

I've also tried disabling IPv6, didn't work.

Any help would be great as the wife is not overly IT savvy and currently has to use the laptop while I'm not home, unless I do the above before going to work in the morning.

Thanks in advance!
 

Question Info


Last updated July 17, 2018 Views 48,529 Applies to:
Answer

Windows 7 Forums:

http://social.answers.microsoft.com/Forums/en-US/GettingReadyforWindows7/threads

Above link is "Getting Ready for Windows 7" Forum.

http://social.technet.microsoft.com/Forums/en/category/w7itpro/

Above link is to Windows 7 Forums, for more Technical questions about windows 7.

All Windows 7 questions should be directed there.

You are in Vista Forums.

Cheers.


Mick Murphy - Microsoft Partner

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

This is NOT a driver issue or a TCP/IP configuration issue...although it's a good idea to make sure you are using the latest chipset drivers from your  manufacturer.

Go to Control panel ... then administrative options.
Then "services".
Scroll down and find a service named "Bonjour service". double click on this service, then disable it. Now choose "automatic (delated start)".
Click OK then close everything and reboot, when you do, your network and internet connection should be fine.
Takes a lot to explain the problem but it is a service created by Apple that is commonly used in several applications to get your network card to configure itself
automatically to work with certain services. It does not play well with windows services as a rule, and delaying the auto start gives the windows services time to start prior to its activation at reboot.
Hope this helps!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.