Computer won't reconnect to Internet after sleep mode

This appears to be a common problem, but I have only recently started to experience it. I have found plenty of suggestions but no satisfactory solution after several hours of research.

I am running a wired ADSL Ethernet connection using a Broadcom Netlink Gigabit network card and a Zyxel 660HW modem. The Internet connection works fine except when I wake the computer from sleep mode. In the past the computer would always reconnect automatically to the Internet after sleep mode, but now it usually does not. I stress “usually” as sometimes the computer DOES reconnect, but more commonly I get a red cross over the connection icon and Vista informs me that the network cable is unplugged (which is rubbish). I can reconnect by doing some or all of the following:

Physically disconnecting and reconnecting the cable
Going to Device Manager, locating the network card and disabling and re-enabling the device
Turning the modem off and on again

This problem never occurs when I shut the computer down fully and restart.

I have tried the following suggestions:

Unchecking the “Allow the computer to turn off...” box in the network card’s Power Management settings
Disabling IPv6
Using a different cable
Running the ipconfig release/renew commands
Setting a different duplex speed
Updating all relevant drivers/firmware/BIOS
Checking in BIOS for sleep mode options (there aren't any)
Restoring the computer to the earliest possible time

The above are the most commonly suggested “fixes” but none of them solves the problem permanently.

I did wonder if the modem or network card is at fault but I experienced wake-up internet connection problems with a Speedtouch USB modem too. I also know other people who are experiencing the same thing with Windows 7.

I write this more in hope than expectation as the problem has been around for a while and seems to come and go without anybody knowing what causes it. Of Vista’s many bugs this is one of the most annoying as sleep mode is a useful facility and I can’t use it while the problem persists. The fact that this problem does not happen every time suggests to me that the sleep/wake cycle is not always functioning as it should – perhaps it has been compromised by a dodgy update.

Any enlightenment gratefully received.

 

Question Info


Last updated September 15, 2018 Views 36,578 Applies to:
Answer
I had these same problems running Windows 7 with a 3600hgv gateway (Uverse) and an Intel 82562v-2 10/100 network adapter.  All suggested solutions did not work until another forum led me to try changing "Link Speed & Duplex" in the adapter's Properties>Advanced from "Auto Negotiation" to "100 Mbps Full Duplex".  Problem solved.  Note: I still have "Allow the computer to turn off..." unchecked, but I don't think that had anything to do with resolving the problem.

20 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.