"Unable to select TWAIN source" - Canon LIDE 25 scanner issue

Hi.  I had been running Windows 7 Ultimate RC, since July.  When I plugged in my scanner, it went and found the correct software (CanoScan Toolbox), and my scanner worked perfectly. 

This weekend I installed Windows 7 Pro.  When I plugged in the same scanner...nothing happened.  So I installed the CanoScan toolbox, using the setup CD that came with the scanner.  I didn't think much of it.  Subsequently, I pushed a button on the scanner, and Windows Fax and Scan opened, and the scanner made a terrible noise.

When I open the CanoScan toolbox, and try to scan, it says "unable to select TWAIN source."  I have tried the troubleshooter, downloaded the driver and the entire CanoScan program (for 64-bit Vista) from Canon's website, and tried many other fixes. 

Any advice would be appreciated.

Thanks.
 

Question Info


Last updated October 16, 2019 Views 5,409 Applies to:
Answer
Answer
I managed to get it working.  I am not entirely sure what caused it to work, I kept trying different "Vista" downloads from Canon's website.

Thanks.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.