Tun miniport adapter #2 in vista?

I run vista home basic sp2 and when I check my device drivers, I have an alert next to Microsoft Tun Miniport Adapter #2  with the error code 10 saying it cannot start.  What is this, and how do I fix it?!  Any help is really appreciated!
Thanx
Answer
Answer

Everyone in this thread who is having connection issues, here are some steps that should help your resolve the problems.

To reset the TCP/IP stack go to this article and either click on "Fix it for me" or follow the instructions to fix it yourself:
http://support.microsoft.com/kb/299357

Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog

Disable IPv6:
Try uninstalling IPv6 on all interfaces, removing any IPv6 virtual adapters, and resetting the TCP/IP stack.  To remove IPv6, go into the properties for each network adapter and either uncheck the box next to the protocol "Internet Protocol version 6 (TCP/IPv6), that will disable it, or select it and click uninstall, which will remove it off the computer.  Then go into device manager and remove any 4to6 adapters, miniport adapters, or tunnel adapters.

NOTE: You should do this for each network connection.

Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers
To resolve this issue, disable the DHCP BROADCAST flag in Windows Vista. To do this, follow these steps:
Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.
If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
On the Edit menu, point to New, and then click DWORD (32-bit) Value.
In the New Value #1 box, type DhcpConnEnableBcastFlagToggle, and then press ENTER.
Right-click DhcpConnEnableBcastFlagToggle, and then click Modify.
In the Value data box, type 1, and then click OK.
Close Registry Editor.
By setting this registry key to 1, Windows Vista will first try to obtain an IP address by using the BROADCAST flag in DHCP Discover packets. If that fails, it will try to obtain an IP address without using the BROADCAST flag in DHCP Discover packets.

The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.

To flush the DNS cache:
Click Start, type cmd in the Start Search box, and then click cmd in the Programs list.
If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
Once at the command prompt, type ipconfig /flushdns

If having problems connecting to a wireless router:
Try changing the channel on your router.  Start at channel 13 and go down one channel at a time.  There could be a non-broadcasting router in your area on the same channel as yours.

Go to Control Panel > Network and Sharing Center. Click on "Manage wireless networks".
Remove all other networks except yours.
Right click on your network.
Click Properties.
Open Connection tab.
Do checkmarks on "Connect automatically when this network is in range"
and "Connect even if the network is not broadcasting"; and remove checkmark
from "Connect to a more preffed network if available".

Let us know if this resolves your issues.
Thank you,


Gloria
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 25, 2019 Views 71,515 Applies to: