Prolific PL2303 USB-to-Serial port adapter driver fails to install

I am trying to install a Prolific PL2303 USB-to-Serial port 1ft. adapter cable. This particular one made by Sabrent. It seems that lots of people don't have any issues, and they have XP, Vista, and Win7 drivers available for it. I downloaded the latest Vista driver installer from the Prolific website (, 12/2/2009). The driver says it installed. I then do a reboot. After system is up, I plugged in the cable. Windows detects I inserted the USB and displays the searching for drivers dialog. Odd I thought. I click to watch the status and it ends with the message:

"Prolific USB to serial comm port (COM4)  - Failed"

In device manager it shows a question mark next to it. If it's a Vista driver, why would it fail? What can I do to get this to install?

I also have another Vista machine that I tried it on, just to see if it was that machine or what. It failed too!?


Thanks for the quick reply. I wasn't installing as the "Run As Admin" link at first, even though my account has Admin rights. But yes, then I started doing that, no change.

However, I'm happy to say I found the problem! After posting this, I did a search in these forums and came across ONE other post that had lots of feedback...someone in that one posted a link to drivers which I had not tried. The thread is here: .

The Vista drivers from cooldrives ( did the trick! I have no idea of the lineage of this driver package but they worked. And they worked when the ones on the included CD did not; when the ones from the Sabrent website did not, and when the ones from the Prolific website did not.



43 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated May 19, 2021 Views 417,554 Applies to: