Problems with my USB U3 Cruzer

I am trying to help a friend with her new U3 cruzier.  I was showing her all of the different options on it and it will not open.  We are getting this message

Windows has allocated a drive letter to the U3 drive that is already taken by another drive on your machine or there are no more drive letters available on this machine.  Try disconnecting any network drives that you have connected to your computer and restart U3 by double-clicking LauncU3.exe or the U3 System CD-ROM icon.  Once the U3 launchpad is running, you can reconnect the network drives.
If you do not have administrative privileges that allow you to disconnect network drives, contact the system adminstrator.
For more troubleshooting tips click the Troubleshoot Button.



I have tried clicking on the troubleshoot button and nothing happens. 
I went into my computer to tools and disconnect network drives but there is nothing in there to disconnect.  I tried looking in google to find another solution and I found this link http://www.mydigitallife.info/2007/11/08/change-or-delete-system-drive-letter-via-registry-to-remove-conflict-usb-or-firewire-drive-letter/ and have tried to do this as well.  Again nothing happened.  I am still recieving the same message.

Yesterday I used my U3 Cruzier and it worked fine.  When I tried it today I am getting the same message.  This is a new computer (she has had it 2 weeks)

Her System Summary on her computer reads as follows
OS Name                        Microsoft Windows Vista Home Edition
Version                          6.0.6001 Service Pack 1 Build 6001
Other OS Description       NOt Available
OS Manufacturer             Microsoft Corporation
System Manufacturer       eMachines
System Model                 EL1300G
System Type                   X86-based PC
Processor AMD                Athlon(tm) Processor 2650e, 1600 Mhz, 1 Core(s), 1 Logical Processor(s)
BIOS Version/Date          Phoenix Technologies, LTD R01-A2, 10/04/2009
SMBIOS Version              2.5
Windows Directory           C:\Windows
System Directory            C:\Windows\system32
Boot Device                    \Device\HarddiskVolume2
Locale                            Canada
Hardware Abstraction Layer                 Version = "6.0.6001.18000"
Time Zone                     Eastern Daylight Time
Installed Physical Memory (RAM)            2.00 GB
Total Physical Memory                           1.75 GB
Available Physical Memory                     959 MB
Total Virtual Memory                             3.74 GB
Available Virtual Memory                        2.58 GB
Page File Space                                     2.04 GB
Page File                                               C:\pagefile.sys

Hope this is enough information.  I would really appreciate any help that you can give me.

Thanks

Answer
Answer

Hello Ntivewomn,

Thank you for using the Microsoft Vista Answers Forum!

With the steps you have taken so far, it should have resolved this issue. Have you tried to restart your PC and check if that will correct the error? You may also want to try connecting your USB drive to another PC at least to rule out the possibility of a bad USB flash drive.

Meanwhile, here is link to the support page of SanDisk on how to trouble shoot this issue using another method. Good luck!

Cruzer flash drive could not be detected due to drive letter conflict

Hope this information is helpful


David O
Microsoft Answers Support Engineer
Visit our and let us know what you think.
David O

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated March 20, 2021 Views 3,116 Applies to: