Problem with eHome Infrared Receiver Driver

I have a USB Infrared Receiver that I got from Dell that came with my old computer (XPS 210, I had to have my computer replaced though...the motherboard was fried on it). When I plug it as usual Windows searches for a driver and installs it. The driver for this is "eHome Infrared Receiver (USBCIR)" as it's listed in the Device Manager under the USB devices. After it is installed there is a green light on the receiver and everything works fine, the remote (came with the receiver) works fine as well.

However, everytime I restart my computer, Windows finds the device again only as an Unknown Device. The receiver does not have a light on it thus it doesn't work. In order for it to work again I have to unplug and plug it back in.

I've tried uninstalling the device from the Device Manager and installing the driver again but this doesn't fix the problem. I also tried different USB slots...doesn't help. I'm not using any USB Hubs, just the slots on the tower. All my other USB devices work fine.

I've already searched the internet only to find that apparently no one is having this problem. The receiver worked fine with my old computer, nothing went wrong. My old comptuer ran Windows Vista Ultimate 32-bit (x86) but this one runs the same only 64 Bit, could be the problem.


OS: Windows Vista Ultimate (x64 Bit)

Any help is appreciated.
 

Question Info


Last updated November 2, 2018 Views 51,202 Applies to:
Answer
Hi guys,

Have you guys double check with Dell to see if they provide an update 64 bit driver for the remote? or with Phillips?  The firmware might need to be update also if possible. 

Let us know if you need further assistance,
Kevin
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Kevin

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.