prints stuck in print queue - no printing

We bought a new acer pc with vista home premium installed a month ago, since then nothing but trouble with the printer.  I originally had this problem with my older Lexmark printer, but when no-one could solve it not even Lexmark, I bought a new epson sx200 printer.  I now have the same problem with the Epson printer.  We have had to do 3 system recoveries but the problem comes back.  It seems to be Windows Updates that are causing it!!! 

The printer installs normally and works fine until after updates are installed.  The print jobs are sent to the print queue and there they stay forever.  The cancel all documents option doesn't work.  It shows as deleting in the status for a while but then when you go back they are still there!  I managed to empty the print queue using the fix it option on microsoft but the problem remains.  If I click on the printer properties, and then try to access any of the tabs (ports) etc it stops responding and stays on the general tab.  If I try to uninstall the printer, it asks for permission opens the dialogue box and freezes, nothing happens.

My engineer who installed the system for me made a manual restore point, before updates when everything is working but even this finds a problem and doesn't complete sucessfully.  I am at the end of my tether - we have had a brand new pc and printer for a month, and we still can't use it properly.. my children can't print homework and I can't print my documents.  I don't want to do another system recovery because this loses all my wireless internet connection, and I have to move the pc to another room set it up again.  We can't save anything on the computer because if we have to do a system recovery we will lose it all.  Please, please help me!!!  Although I work on computers all the time - I am no IT specialist.
 

Question Info


Last updated May 27, 2019 Views 22,367 Applies to:
Answer
Answer

This error means exactly that your setup was desperately waiting for Print Spooler Service to react somehow. But that didn't happen in the required period of time.

Now, we figured out that you have a problem with Print Spooler.

Please, go to Control Panel -> Administrative Tools -> Services and make sure that Print Spooler service is set to Automatic and is Started.

Also, go to Administrative Tools -> Event Viewer and search for error events for Print Spooler. What is said there?

Also, you may want to try steps from here: http://support.microsoft.com/default.aspx?scid=kb;en-us;324757 (that's for XP, but should also work for Vista). Also, try last suggestions on Lexmark from here: http://members.shaw.ca/bsanders/CleanPrinterDrivers.htm (note that much of info on this link is the same as on the MSFT link above).

Please, inform us if this helps or you need further assistance!

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.