Error 0x8007045D while copying files from computer to external hdd

I am trying to copy some files to my external HDD. but i get this error (Error 0x8007045D: the request could not be performed because of an I/O device error).

I performed windows check disc to my external hdd, i tried to perform windows defrag but it takes too lonc and cancel it(External HDD is 1TB) . I download a defrag software and defragged my hdd on fast mode(Software is O&O Defrag). I tried it on another computer and i got the same error. Is this a hardware problem. Are there any possibility to fix it. Thank you for helping

 

Question Info


Last updated November 1, 2019 Views 27,845 Applies to:
Answer
Answer

Hello Nyfixen,

1.     Did you change the permission for the External hard disk or the files that you were trying to copy?

2.      Do you have any important data (files) saved on the External hard disk?

3.      Are you able to copy from the External hard disk to the computer?

The Autorun.inf could not be an issue for this. It still appears to be a permission issue to me. Some hard drives have a jumper on them for write protect. You need to check the jumper settings, please check the manual which came along with the hard disk for permissions.

http://windows.microsoft.com/en-US/windows-vista/What-to-know-before-applying-permissions-to-a-file-or-folder 

Format hard disk:

Check out this article for information on this:

http://windows.microsoft.com/en-us/windows7/Create-and-format-a-hard-disk-partition

Thanks,
Irfan H, Microsoft Answers Support Engineer. Visit our Microsoft Answers Feedback Forum and let us know what you think.

45 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.