Vista: Window's Explorer incorrectly sorting

While using Vista Home Premium, I find when ever I try to sort information, it doesn't sort it correctly.  The most obvious example is when I ask it to sort a folder by Date Taken or Modified, it doesn't sort the object correctly, as I'll find new files toward the top, and clearly next to other things that aren't relatively close to the same date.  Because I look at a lot of pictures and go through those constantly, I need to be able to find the latest pictures taken and quickly.  XP never had this issue, so I wonder why there is on on Vista?

Help would be wonderful.
 

Question Info


Last updated June 11, 2019 Views 2,425 Applies to:
Answer
Answer

Hi thedrummer_rpg,

Welcome to Microsoft Windows Vista Community site. Just wanted to check if you can successfully sort files by other properties such as by Name, Size and Type?

Also check if the Option is working without any issues in command prompt.

dir [drive:][path][folder name] [parameters]
Where D is the parameter for sorting according to Date and Time

Meanwhile I would suggest you to tryout these options:

Option 1: Here's my way to get around the annoying change of folder details with the templates:
(This won't work on the C Drive Root as the option isn't there in properties, just click a folder instead):

Step 1: In explorer, right click a drive, select properties, select Customize;
Step 2: Ensure it is set to "ALL ITEMS" template, click OK.
Step 3: Set up the look and tags as you like it, go to TOOLS, FOLDER OPTIONS, select VIEW, APPLY TO FOLDERS, click OK.
Step 4: Then RIGHT CLICK the Drive Root again and select PROPERTIES and CUSTOMIZE with 'ALL ITEMS' as the template, place a tick next to 'also apply to all subfolders'.
Not a perfect solution, but works around the annoyance.

Option 2: It is possible that last access has been disabled on the file system.

Open a command prompt and enter:
C:\>fsutil behavior query DisableLastAccess
If you get "DisableLastAccess = 1" it has been disabled.

You can enable it by entering:
C:\>fsutil behavior set DisableLastAccess 0 


Let me know if that does or does not work. Good luck!
Hope this is helpful. 

Thanks and Regards,
Vijay KKS


[If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.