Windows Identity Foundation not working with Technical Preview.

I have tried several solutions to get Windows Identity Foundation installed on the Tech Preview.

1. Download MSU and install Windows6.1-KB974405.msu - fails with "certificate for the signer of the message is invalid or not found"

2. Intsall from add/remove Windows features - it is not listed as a feature to add

3. Use DISM to install Windows-Identity-Foundation - fails with "feature with that name was not found"

How can I get WIF installed on the tech preview?

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

I suggest you to refer to the following Microsoft Help article before installing Windows Identity Foundation. This article consists of more information about installing this in Windows 10 Technical Preview.

http://www.microsoft.com/en-us/evalcenter/evaluate-windows-technical-preview-for-enterprise

Please reply if the information provided is not helpful so that we can help you better.

Basith M
- Forum Moderator (Multiple Forums)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Are you saying I need the Enterprise version of the Tech Preview to get WIF installed?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Are you saying I need the Enterprise version of the Tech Preview to get WIF installed?

Installing the Windows 10 Technical Preview for Enterprise does not add Windows Identity Foundation. I have that installed and it is not available.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

From Windows 8.1 Features Screen:

WIF 3.5 has been superseded by WIF classes that are provided as part of .NET 4.5. It is recommended that you use .NET 4.5 for supporting claims-based identity in your applications.

so i guess they removed it completely in Windows TP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So If I have an application that was not written for 4.5 yet and still uses WIF from 3.5....this application won't work on Win 10 TP?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found a workaround in this post: http://answers.microsoft.com/en-us/windows/forum/windows_8-windows_install/error-when-installing-windows-identity-foundation/6e4c65a5-ea24-431c-b4f0-b8740e97cf46

There are a few assumptions: 1) that you can get the file out of the GAC on your local machine (map a network drive to \\<your machine name>\c$\windows\assembly). That will give you an explorer view with the actual files, and 2) that you know how to install a file to the GAC using gacutil (included with Visual Studio)

To do it: copy a 3.5 version of Microsoft.IdentityModel.dll from a machine with it installed to your Windows 10 Tech Preview machine and use gacutil (if you have it installed, comes with Visual Studio) and run:

gacutil /i c:\<path to Microsoft.IdentityModel.dll>

Worked for me and my connection to MS CRM. Didn't even need any other dependent DLLs. Definitely a workaround, but it got me past my issue.

HTH.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tried that - does not work for Installation of Dynamics AX :(

Any other ideas?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue, running AX 2012 R2 CU7 and cannot install the client because WIF is not available as an installable feature for Windows 10 ETP.

In fairness, there is no way you'd receive any support from Microsoft for running Dynamics on evaluation software!


I guess there must be some rationale behind the decision, or perhaps an architectural problem supporting WIF in the next generation of Windows.

I would say we're just going to have to wait 12 months until the Dynamics AX product cycle upgrades and it moves off its current dependencies.  

Until then, Windows 7/8/8.1 will have to remain the default OS for AX client users.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

First of all, I would like to apologize for the delay in responding.

The issue that you are facing is better suited in Microsoft TechNet forum, we have a dedicated team to help you with this type of issues. They have advanced tools to work with this type of issues. I suggest you to post the same question in Microsoft TechNet forum for further assistance with this issue.

http://social.technet.microsoft.com/Forums/en-US/home?forum=WinPreview2014General

Basith M
- Forum Moderator (Multiple Forums)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just a heads up, the feature is back in build 9888 (not officially available for public)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated March 31, 2019 Views 2,472 Applies to: