Nvidia optimus not working properly

I have a issue with nvidia optimus on Windows 10 TP. I installed the latest drivers, but nvidia optimus is still not working.

Anyone knows some workaround to start manually optimus service?

My Laptop is: Lenovo Z510
CPU: i7-4702MQ

RAM: 8.00 GB

GPU: NV GT 740M
nvidia driver: 344

*****************************************************************

Update: October 3rd

I tried to downgrade Intel Graphics driver to version from the answer. And it still cannot launch some DirectX 9.

The strange thing is that even before the downgrade games that are using DirectX 10 and higher were running without any problems. Only some games that are on Unreal Engine and using DirectX 9, like Mass Effect or Borderlands were not running on Nvidia GPU. And yes, i had already installed DirectX 9.

I'm still gonna leave that reply as an answer, because on nvidia forum  were other people who reported that this workaround fixed their problems.

 

Question Info


Last updated January 20, 2019 Views 24,779 Applies to:
Answer
Answer

In found this on this forum elsewhere:

I don't know what kind of system you're running, but I was able to clean up some of my graphics issues on my laptop running Intel HD Graphics 4600 integrated and Nvidia GeForce GTX 780M dedicated by downgrading my Intel drivers to 15.33.22.64.3621.

I tried it and was able to several of my MMOs to run. Hope this helps someone else.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.