Vista SP2 Update Fails - "No such interface supported" Details - "Error: E_NOINTERFACE(0x80004002)"

Good morning.

Stand alone Vista SP2 Fails.

Using Windows6.0-KB948465-X86.exe file version 6.0.6002.18005  downloaded 5/26/09 2:03pm Central

"Installation was not successful"   "No such interface supported"   Details - "Error: E_NOINTERFACE(0x80004002)"

I follow the Go online to learn more... link.

Resolution 1: Install the stand-alone package...  -  I am using the Standalone Package

Resolution 2: Run the System Update Readiness Tool - I did. No change, install still fails.

Resolution 3: Close or disable any applications...  - I did. No change, install still fails.

Resolution 4: Uninstall any security applications...   I did. No change, install still fails.


I have also run a check disk and run the SFC command to scan for corruption.  No change, install still fails.


This particular PC is a Gateway with pre-installed Vista Ultimate.  I installed SP1 via Windows Update a ways back.  It currently has all critical Windows Updates installed, exception of todays Windows Defender updates.

I have NOT installed: IE8, Windows Power Shell 1.0, Office Live Add-in, Windows DreamScene Pack #3, Windows Sound Schemes, Windows Live Essentials nor any of the 34 Language Packs

The PC has been scanned by multiple commercial grade malware programs, with the PC active and with the drive attaches to another machine. It is clean.


The PC is connected to a USB keyboard and wireless Logitech Mouse via a DVI/USB KVM device. (There is no Logitech software installed)

There are no other external devices attched to the PC. The printer is via wireless network.

UAC is turned off.

The hard drive has the main partition "Drive C" and the recovery partition "Drive H"
The DVD/RW is "Drive I"
The Card Reader in the PC has Drives D thru G
The Card Reader on the wireless HP C6180 shows as a network drive Z

Please send help.

 

Question Info


Last updated September 28, 2018 Views 24,921 Applies to:
Answer
Answer

I realize many of you may have given up and just reinstalled Vista or moved on to W7 at this point.

I was having the same issues as Coherent Computer Solutions.  I had narrowed the issue(s) down similarly and had gotten to the point where it seemed likely to me that the WMI issues were somehow related to the inability to install SP2.  I too was getting "Can’t Collect Information.  Cannot access the Windows Management Instrumentation software. Windows Management files may be moved or missing."  Attempting to install Vista SP2 consistently wound up with "No such interface supported" Details - "Error: E_NOINTERFACE(0x80004002)"  I had tried all the other suggestions found throughout this thread, especially in the sixth post.

I had already run the command "net localgroup Administrators LocalService /add" to resolve some problems with network connectivity.  I was receiving the message "Connection status: unknown.  Server execution failed"  when attempting to launch the Network and Sharing Center.  The "net localgroup Adminsitrators....." command fixed this beautifully.

But I was still getting the WMI error(s) and, as mentioned, also attributed the inability to install SP2 (No such interface supported) as being probably related to this. More digging and wmidiag showing similar errors reinforced this belief.  Finally, a bit more searching turned up this command:

net localgroup administrators NetworkService /ADD

Make sure to run it from an elevated command prompt (right-click and run as Administrator).  But, after running this command, msinfo32 worked perfectly and, lo and behold, Vista SP2 installed cleanly (and rather quickly, actually).  I hope this helps someone else out there and thanks to Coherent Computer Solutions for the msinfo32 WMI lead.  Happy holidays to all.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.