Error Code: 0x663

Started when I tried to install upgrade for .NET Framework 3. It failed and I found directions that told me to uninstall all versions of .Net Framework and then reinstall them one by one. I got .Net Framework 1.1 installed and when I went to Microsoft Updates I found an upgrade for.Net Framework 1.1 SP1. I tried to install that upgrade and got the above error (0x663).
 

Question Info


Last updated March 25, 2018 Views 3,282 Applies to:
Answer
Answer

Hi slborne,

 

 

1.    Do you have any security software installed on the computer?

2.    Are you able to install all other updates on the computer?

 

 

I would suggest that you reset the Windows update components to default and later try to install the update.

How do I reset Windows Update components?

http://support.microsoft.com/kb/971058

 

If the above step fails then I would suggest that you manually install the update using the below link and check if it works.

Microsoft .NET Framework 1.1 Service Pack 1

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&displaylang=en

 

Hope this helps!

Halima S   - Microsoft Support.

Visit our  Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.