Question
11186 views

Windows 7 SP1, 0x800F0A12 error code

BBSMITH2 asked on

I'm receiving the 0x800F0A12 error code.  Currently I have 3 OS's, XP home, Linux and Win7 home, on three different drives and I am using GRUB to as my boot loader. 

 

When I go to install SP1 I'm getting the error.  From what I can tell it's because I'm using Grub to control which OS I boot instead of Windows 7.  I tried DiskPart and enabling this drive and restarting to no avail. 

 

Short of unplugging the other two drives and installing SP1 that way is there another way I can try this?  Is there an ISO or EXE file I can install from or will I still end up with the same error message?

 

Thanks for your help.

 

Bruce

13 people had this question

Abuse history


The answered status icon Answer
D. Charles Pyle replied on

First things first. Is your Windows partition on your primary drive? Is GRUB also located on your primary drive with a boot partition containing the second element of GRUB? If so, try to do the below.

  1. First, try installing Service Pack 1 while in Windows 7 Safe Mode. If that fails with the same error, try the below. Note: If you are trying to update using Windows Update, you will need to boot Windows 7 inSafe Mode with Networking, although this might not work. the best approach is to download the individual files for your system from the Download Center or make a DVD from the Service Pack 1 ISO that Microsoft makes available on their site. Failing this, try the below next.
  2. Use the Disk Management snap-in in the Computer Management Console (get to it by right-clicking onComputer and selecting the Manage menu item) to check whether your Windows partition is marked as 'active.' If it is not, use the snap-in to mark it active by right-clicking on the Windows partition and selecting the menu optionMark partition as active. The installer should run without further problem relating to the above error.

Before doing the change, however, make sure that you write down which partition on your primary drive was marked as active so that you can set it back using Microsoft's DISKPART.

If your partition already is marked active, then it is another related problem, the solution to which likely will be found on the relevant Microsoft support pages for Service Pack 1.

Typically, the problems I have seen relate to the use of GRUB and other like-minded third-party boot managers. GRUB will run from the MBR and then run code in the boot sector relating to a Linux installation. Typically, this means that your Linux installation is on the primary drive or that the Linux partition is the active partition at boot time before it chainloads Windows 7 boot code from its own partition.

If neither is the case, then it is likely that you will have to make your Windows drive your primary drive and disconnect the others by removing the power cables from the other hard disk drives. The system should not see them once you do that. GRUB may have a fit, however, and, if so, you will need to use advanced options (some versions of Linux require the pressing of 'e' and then manually editing the boot options) and change/remove references to other drives and partitions in the GRUB boot menu before attempting to boot.

It is also possible that the system will not boot without GRUB if the Windows boot manager code is not installed in the Windows partition on that drive, or if GRUB is not installed on that same drive, which may then require a re-install of the OS (you can perform an 'upgrade' install which will preserve settings and applications) and then installation of the service pack. After doing this, you should then be able to plug the power back into the other hard disk drives and continue as before.

6 people found this helpful

Abuse history


progress