.NET Framework 4 Installation Error: No signature was present in the subject

After trying to install .NET framework multiple times, it hasn't worked yet. I can't find a solution that works, so I decided to post here. I am running Vista with Service Pack 1, and the log file can be downloadedhere. I ran the standalone installer, because of issues I had downloading the necessary files during setup. If there is any more information you need, just say so.
 

Question Info


Last updated July 4, 2019 Views 13,242 Applies to:
Answer
Answer

Hi B3tturTh3nU,

 

Step 1: Run the System Update Readiness Tool (Checksur.exe). To do this, follow these steps:

 

To resolve this issue, run the System Update Readiness Tool (Checksur.exe). To do this, follow these steps:

1.   Download and run the System Update Readiness Tool. This tool runs a one-time scan for inconsistencies that may prevent future servicing operations. For more information about how to download and run the Checksur.exe tool refer the link below

Description of the System Update Readiness Tool for Windows Vista

http://support.microsoft.com/kb/947821/

Step 2:Run the fixit available in the link below to reset windows update components.

 

How do I reset Windows Update components?

http://support.microsoft.com/kb/971058

 

Now try to install dot net Framework

Refer the link below

 

Error message when you try to use the Windows Update or Microsoft Update Web sites to install updates: "0x800B0100"

http://support.microsoft.com/kb/956702

 

Thanks and Regards:

Ajay K

Microsoft Answers Support Engineer

Visit our Microsoft Answers Feedback Forum and let us know what you think

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.