Microsoft update showing blank screen

I have a problem with windows update, it shows a blank screen with #ElementModuleHeaderText#
#ActionCustomInstallImportant#
#ActionCustomIntstallOptional#

and that's it nothing else the page is blank, no cancel nothing. Do you have any ideas what it could be and how to fix it?  Thanks for the help.

I haven't downloaded anything in the last few weeks, and as far as I can tell no updates have been installed for a couple of weeks.
 

Question Info


Last updated February 1, 2020 Views 30,708 Applies to:
Answer
Answer

Try the following:-

Open the Vista Start Menu search Bar and type: RUN

Click OK

Type the following lines and after each one click OK:-

regsvr32 jscript

regsvr32 vbscript

regsvr32 /i mshtml

No guarantees

You may have to reboot a couple of times, Vista likes reboots.


TaurArian [MVP] 2005-2010 - Update Services
No warranties or guarantees.
MVP 1st July 2005- 30th June 2016
WIMVP 1st July 2016- 30th June 2017

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi Whizzie,   

Welcome to Microsoft Vista Answers Forum!  

You may try the steps as below and check if the issue gets fixed.

 Step 1: Reset Windows Updates Components.

 To reset the Windows update component you can follow the below provided link.

 http://support.microsoft.com/default.aspx/kb/971058

If the above provided solution does not resolve the issue you can follow step 2 to perform a clean boot. 

Step 2: Clean Boot Troubleshooting. 

1. Click Start, type msconfig in the Start Search box, and then press ENTER.

       User Account Control permission

       If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

2. On the General tab, click Selective Startup.

 3. Under Selective Startup, click to clear the Load Startup Items check box.

 4. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable      All.

 5. Click OK.

 6. When you are prompted, click Restart.

 7. After the computer starts, check whether the problem is resolved.

If the issue is resolved check which third party is causing the problem, referring the link given below:

http://support.microsoft.com/kb/929135

 Reset the computer to start as usual

After you have finished troubleshooting, follow these steps to reset the computer to start as usual:

Click Start, type msconfig.exe in the Start Search box, and then press ENTER.

If you are prompted for an administrator password or for confirmation, type your password, or click Continue.On the General tab, click the Normal Startup option, and then click OK.

When you are prompted to restart the computer, click Restart.

Hope this information is helpful.

Thanks and Regards:

Suresh Kumar- Microsoft Support.

Visit our Microsoft Answers Feedback Forum http://social.answers.microsoft.com/Forums/en-US/answersfeedback/threads/  and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.