IE7 png files not displaying; White box Red X

I’m wondering if anyone is experiencing this as well? On a Windows XP, SP3 laptop, with IE7, fully patched system as of last Tuesday (6-8-10); I’m seeing issues with User level XP accounts (not seeing this issue with Administrator level accounts) not being able to see PNG images in IE7. They see White box, with Red X in the upper left corner.

 

I had the newest ZoneAlarm 9.2.x,I fully uninstalled that, didn’t help. Have AVAST 5.0.545 installed, turned that off, didn’t help. Have done ALL the troubleshooting in http://support.microsoft.com/kb/283807 to no avail.

 

And I have tried re-registering the pngfilt.dll as well perhttp://www.pcreview.co.uk/forums/thread-674590.php, but get “dllregisterserver entry point was not found - the file cannot be registered” error. Then read this about using “regasm” instead of “regsvr32”:http://social.msdn.microsoft.com/Forums/en/vbinterop/thread/d5c5ff4a-63d3-49ea-a20d-50ef45924b2e Never heard of regasm B4.

 

Wondering if anyone has any input?Thanks.
Answer
Answer

Hey PA BEAR,

 

I can’t see any of my posts in my MS Social Forum profile here? Any idea why? I had to Google to find my old post here.

 

Anyway, I fixed my own issue. 

 

 

On Test1 "Administrator" level XP account, I removed patch 982381, rebooted, tested IE, same issue. Then uninstalled patch 980195, rebooted, tested browser, same issue. Then re-applied thepng_fix reg files from, http://www.winhelponline.com/articles/202/1/PNG-images-are-not-displayed-on-Web-sites-in-Internet-Explorer.html , and then the IE7 png issue cleared up & I was able to see *.png files in IE7.

 

Then I logged on as a Test2 a "User" level only account, and the *.png issue (can’t view *.png files I IE7) STILL occurred under THAT account. I promoted Test2 to Administrator, logged on and the IE7 *.png issue cleared up and I was able to see *.png files in the browser.

 

I then demoted Test2 account back to "User", logged in & the IE7 png issue browser issue REOCCURRED.

 

Then I reapplied patches 982381 and 980195, (not sure why I did that) same issues. I didn't think it was these patches, looked more like a rights issue.

 

Soooo….then I ran across this MSFIXIT 50198: http://support.microsoft.com/kb/313222 , ran it, voila, cleared up my PNG & IE7 on XP issues with both Administrator and User level accounts!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated March 25, 2018 Views 45,702 Applies to: