Error Code: C000009A (Problems applying update to registry during installation of Windows 7 Service Pack 1)

After the installation of Windows 7 Service Pack 1 the system reboots, and before windows comes up the registry is updated.  I get an Error C000009A applying update 128115 of 387921 (/Registry)  ....    error which stops the system from restarting.  Is there any way to get the system to restart and complete the service pack installation.  The only way I have been able to get around this error is to restore from the system restore point prior to the service pack, but I would like to apply SP1 if at all possible.  ????

 

Question Info


Last updated June 13, 2019 Views 11,864 Applies to:
Answer
Answer

Windows update and SP1 has given me the same problem and I have used this hole working day to SOLVE it.

Windows 7 was not bootable. Windows 7 safe mode was not bootable, - stopping at classpnp.sys.  I used the command prompt from rescue disk and Linux(!) to fix it.  And then some important reading / tips on this forum.

Error message at boot:

    Error C000009A applying update operation 109544 of 262832 (registry\ma...   (no more place on screen)

After a couple of failed reboots I tried a system restore from Windows rescue disk, but windows update has somehow erased all my restore point !!! (Argh)

Then I looked in the log file c:\windows\winsxs\poqexec.log and found a reference to the error: (obs this folder has some 70.000+ files)

1cbd36fd5eb05f3: 74c, c000009a, 1abe7, 0, SetKeyValue ;\Registry\Machine\Software\Microsoft\Windows\CurrentVersion\SideBySide\Winners\amd64_microsoft-windows-e..atibility.resources_31bf3856ad364e35_pt-pt_0b9032dad0ee6ed8\6.1, 6.1.7600.16385, , AQ===

Then I tried to add this key to the registry using regedit from command prompt after booting to rescue disk.  But repeated boots showed that registry didn't take / save my added key. (Strange, - I should be able to change the registry form the rescue disk, or?)

Next step was to boot a Linux live CD (Mandriva)  to browse the windows system disk.

This way I found the c:\windows\winsxs\pending.xml file (99 MB) and could open it in kwrite (in linux).  I search for  "atibility.resources_31bf3856ad364e35_pt-pt". Found that in line 114.808 (of over 300.000 lines).  Add a ! after < to make this xml line a comment.  Saved the file. Rebooted and .. yes .., windows 7 updated some files, rebooted 2 times and then started as normal.

I'll guess MS has created a lot of angry people today!!!

The  amd64_microsoft-windows-e..atibility.resources_... file is probably related to

a) ATI/AMD Graphics Cards (as in my system)

b) Windows MUI system (Multilingual User Interface) in windows 7 ultimate.

    pt-pt is a code for some language.  (Not mine, I am from Norway, NO.)

 

on Windows 7 ultimate (again)

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.