Windows Vista SP2 installation error loop (x64)- Error code 0xc0190036

Hello, After installing the SP2, I've constantly getting the same error, the bad thing is, insteath of rolling back, the SP2 update keeps trying over and over and over to change the file that contains an error ( file checks as ! error 0x00190036 mshtml.tlb ! ).
now.. I think microsoft really screwed it this time, because the installer does run in any windows mode, Ie, cant go to safe mode to attemp to recover from there, it just AGAIN attemp to install the botched SP2, restarting computer does nothing, as the updater again will activate itself, so I always end stuck in that part of the file mshtml.tlb with that error code (it keeps blinking constantly like its trying again and again to access the file )

Specs: Windows Vista SP1 Ultimate x64
GA-X48-DS4
Kentsfield Q6600 @ 3 Ghz.
4 x 2 GB ( 8 GB ddr2 800Mhz)
Sapphire Hd 3870
2 x WesternDigital Caviar (500 + 160 Gb ) + Seagate 250 GB
Sound Blaster Audigy 2 Zs

Prior errors: I could never manage to install IExplorer 8, it always reported a similar error, but with the file ieunit (cant remember the exact file extension currently)

so the question is: will there be a fix for this problem? or should I just rollback and try to recover manually in the hardway ( Ie, running the Vista's cd repair tool )
im not keen of using the repairtool, because it already ruined one installation once after a bad patch from windows update.



*edit*
just to fix the wrong error code, the correct error code reported is : 0xc0190036

sometimes the error is then changed to 0x0190002 then to 0xc0190005 when shutting down.

note that im on windows vista SP1 ultimate x64
-= Noob Programmer =-
 

Question Info


Last updated March 25, 2018 Views 21,166 Applies to:
Answer
Answer
Hi Tamalero,

The error message you got indicates that mshtml.tlb is corrupted and there is a possibility of other System files being corrupted as well. All we have to do is rename the corrupted dll files, reboot the Computer and let the Computer boot normally to finish the installation. Follow these steps to rename the corrupted dll file.

1) Insert the windows vista dvd and boot from the dvd.

2) Select Repair your computer.

3) Click on Command prompt

Type the following commands and hit enter after each line

C:

cd windows

cd system32

ren mshtml.tlb mshtml.tlb.old

4) Exit from command prompt

5) Restart the computer and boot normally

If you the get the black screen with a similar error and a different file (other than mshtml.tlb), make a note of the dll file, repeat the steps from 1 to 5 and type that file name in step 3.

Restart the computer. It may take a while and will ask you to login to the desktop.

Check in system properties if SP2 is installed.

Hope this works. If you still have the problem please do post back....

Thanks.

Hi there error_counter:
doing a "repair" only finds boot issues, and once they're resolved, the problems persists (the mshtml.tlb error )
I tried deleting said file, but then the error changed from 0xc01900036 to 0x000034
so I am stuck again, I dont know why the file mshtml.tlb is really important to "detect" if the service pack will update it anyway.

and like I said, even after windows vista SP1 supposedly DID a system restore point, no system restore points were detected by the dvd ( one of the things I hate more of Vista that their restore points are a coin toss, and you can get with a useless non working one anytime.. )

the trick that let me go back to SP1 was following the instructions from another post here, related to the error 0x000034 in this forum but for SP1.
I went to the directory c:\windows\system32 and renaming the files software, security, SAM and default, and replace them with copies from the directory REGBACK inside system32\config
It could get me back to SP1, unfortunately some quirk got me stuck then in a infinite "configuring updates 3 of 3" forever time it boots ( it restarts by itself after a few days ). and had to delete the file pending.xml

this did the trick.. for now, since everything seems corrupted ( I can use the program and work just fine, but no windows update file will work. )
SFC doesnt detect inconsistencies but it doesnt get to 100%, it stops at 34% claiming it had problems, and "couldnt do the solicited operation".
I also tried diferent tools from microsoft. like the URSCheck, and it just says "this update doesnt not apply for your machine".

so I suppose my entire installation is really really corrupted (and makes me really hate Vista more due of it, so far almost all my installations or computers from other people that contain vista, are full of errors or diferent quirkcs that prevents normal usage.

so Im now installing Windows 7 in another partition and Im thinking in whiping this one as soon everything is installed there.



-= Noob Programmer =-
-= Noob Programmer =-

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.