Question

Q: .NET update failed error code 3712

I have tried installing the .NET 3.5 update several times and keep getting the error 3712.  I tried restarting and then reinstalling, didnt work.  I looked in Programs/Features in Control Panel and did not see any .NET installed.  Do i need to have an earlier version installed for the update to work?

Getting the error log below when trying to install .NET 3.5SP1 on Vista

[08/05/09,17:32:34] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/05/09,17:32:41] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.
[08/05/09,17:48:24] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/05/09,17:48:27] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.
[08/05/09,22:49:41] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/05/09,22:49:45] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.
[08/05/09,23:56:04] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/05/09,23:56:09] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.
[08/06/09,13:51:54] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/06/09,13:51:58] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.
[08/06/09,14:26:41] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code 34
[08/06/09,14:26:46] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.

Answer

A:


Hello Firemedic
 
Thank you for writing to Microsoft Vista Community Forums.
 
You may try the following steps:

1. First, create a System Restore Point manually, so that in case, something goes wrong while performing these steps, you may always perform a System Restore.
2. access the link below and follow the steps and try to perform an update:
http://support.microsoft.com/kb/923100
3. Try performing the Internet Optimization.
http://support.microsoft.com/default.aspx?scid=kb;en-us;936213
4. You may also try following the article below to reset Windows Update components.
http://support.microsoft.com/default.aspx/kb/971058
5. Try disabling the security software while running the Windows Update.
 
Hope it helps.
 
Thanks and Regards,
 
Srinivas
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 6,999 Last updated: March 25, 2018 Applies to: