Cannot install Vista SP2 - Code C0000005

I have been trying to install Vista SP2 on my Vista Ultimate x64 system without success.

I first tried with the standalone installer, before the update was available on Windows Update. I launch the installer, a UAC prompt appears and I accept, after which nothing happens.
I have tried to be patient, but all I see is a process named 'Self Extracting Stub' sitting in memory, taking up a mere 5MB and doing absolutely nothing (constant memory usage, 0% CPU).
I tried again when SP2 appeared on Windows Update. It downloads fine but then it gets stuck at the Installing Update phase with an empty progress bar. As far as I can tell, nothing happens here either.

In Windows Update, though, I do get an error when I leave it runnning for about an hour, I've pasted the description below:

--------------------------
Windows Vista Service Pack 2 for x64-based Systems (KB948465)

Installation date: ‎30/‎05/‎2009 22:03

Installation status: Failed

Error details: Code C0000005

Update type: Important

Windows Vista Service Pack 2 is an update to Windows Vista that includes all of the updates that have been delivered since Service Pack 1, as well as support for new types of hardware and emerging hardware standards. After you install this item, you may have to restart your computer. This update is provided to you and licensed under the Windows Vista License Terms.

More information:
http://support.microsoft.com/kb/948465

Help and Support:
http://technet.microsoft.com/en-us/windows/dd767387.aspx
-------------------------

Google is of no help at all in this case, since C0000005 seems to be a catch-all error.

What I have tried:
- shutting down antivirus and firewall software
- running the System Update Readiness module
- scanning my RAM for faults, it's all clean

More info on my system:

Vista Ultimate x64 UK with all updates installed
Intel c2d E8400 and 4GB of RAM, 2x500GB of HDD
8800GT and an Auzentech Prelude

Running Avast! Free as antivirus
According to various virus and spyware scanners, the system is clean, and I have no reason to suspect otherwise.
Running the Vista Firewall with advanced security as firewall
No other background processes of note.

All other things on my PC are running great, with the exception of Vista's "Connect to a wireless network" interface, which won't open and either causes a Rundll32 error or an Explorer crash. I don't know if it's related, but I thought I'd mention it. This is a pretty recent problem.

Any help will be greatly appreciated.
 

Question Info


Last updated March 25, 2018 Views 2,849 Applies to:
Answer
In a stroke of genius (not really), I found the solution to my problem. It's really simple, and in a way, it's also really stupid. The following solution also solved the "connect to a wireless network" problem I mentioned above.

The thing is, I used a patched uxtheme.dll file (and whatever the other file that manages visual styles is called) to use custom visual styles. It turns out that the style I was using at the moment was causing the aforementioned problems. Switching back to the standard Aero theme solved it all, I didn't even need to change the dll files back.

So in case anyone ever comes across a similar problem, i.e. the SP2 installation not launching or the "connect to a wireless network" screen causing crashes, chances are you're using a custom visual style that messes things up a bit.

Thanks, Matt, for the input.

Now the only thing I've left to figure out is why my PC reboots when I tell it to shut down, but I haven't yet determined if that's a Windows problem so I'll have to do some more research :)

Thanks again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.