Unable to connect to GFWL (event viewer - 0x8015190e) earlier error was 80072751

I installed Bioshock 2 and GTA 4 EFLC yesterday and after signing in GFWL gave me an error 80072751 when it tried to update the game. After searching these forums I tried several things -

Allowed through Windows Firewall

Opened ports on router (even though uPnP is enabled)

Reset TCP/IP

Clean boot

Disabled anti-virus (Avast 5)

Ran IGD test (passed)

 

None of these solved the problem so I manually downloaded and installed Bioshock 2 (patch 3) and GTA 4 EFLC 1.1.2.0. Now GFWL won't even sign in on starting the game. The event viewer shows -

BioShock2.exe
   1, 0, 0, 1
   3.2.0003.0 (WGX_XLIVE_v3.02_RTM.100402-1646) C:\Windows\system32\xlive.dll
   0x8015190e XLive Logon Failed 00:26:79:56:5A:F7 192.168.1.2 0xfb0000000061e7a6 LogonHR == 0x8015190e Games for Windows - LIVE DLL

 

EDIT: Forgot to add that Dow2: Chaos Rising, which was working earlier is also giving the same error now.

I'm using Win 7 x64.


Answer
Answer

I finally got GFWL to work by just disabling uPnP on my ADSL model/router.

Sorry I forgot to update here but I had almost given on on GFWL games.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 2, 2018 Views 3,450 Applies to: