Steam.exe(main exception):ERROR:delete of steam.exe failed, Win32 Error5 "Access is denied"

I get the error posted in the title line when trying to install the Steam application for the game Left4Dead. Just in case the title window does not display the complete error message:

Steam.exe(main exception):ERROR:delete of steam.exe failed, Win32 Error5 "Access is denied"

My system specs are as follows:

MB:      ASUS P6T DELUXE Version2
CPU:    i7 950 QUAD-CORE 3.06GHz
GC:      XFX RADEON HD 4890 1GB
RAM:   Patriot 12GB Triple Channel Lat7
HDD:   WD VelociRaptor 150GB 10K RPM
HDD's: Dual Samsung RAID Class 1TB
HDD's: Dual Seagate Barracudas 500GB
PWR:   COOLMAX 1200 Watt
CASE:  Aplus Black Aluminum ATX Full Tower
OS:       Vista Ultimate 64bit

I have checked my system and performed the following tasks to try and troubleshoot the issue:
My version of Windows is up to date. I have no outstanding hardware or driver issues.I have attempted to temporarily disable my antivirus to complete the install, this did not solve the problem. I have attempted the install as a system administrator. I have searched the Valve/steam software website for a solution, none has been found (http://store.steampowered.com/). I have searched the Microsoft database for a solution, none has been found. I am having no issues with any other games or applications that have been loaded on this computer. The problem is just with the steam.exe application and any game which requires the steam application to function.
I came across the following link that promised to resolve the issue;  
http://www.bing.com/search?mkt=en-us&q=Steam%20error%20Win32%20error%205
https://support.steampowered.com/kb_article.php?ref=5322-QYZB-5344  
I followed the instructions three separate times all with the very same error message.
The program by default loads to the following: C:\Program Files (x86)\Steam.
I have attempted to load the program on different harddrives and got the same error code.
I triple checked all of the user profiles to make sure the proper priviledges were set(Admin). I checked all of the Steam program components to ensure they were set to run as an administrator executed program. I double checked that the proper TCP/UDP ports were open for the steam application to function. http://www.resoo.org/docs/counterstrike/steam_ports.html
Any assistance to resolve this issue would be greatly appreciated.
 

Question Info


Last updated August 10, 2018 Views 21,069 Applies to:
Answer

Hello Platinum,
 
Thank you for writing to Microsoft Vista Community Forums.
 
This error is mostly caused by a lack of user permissions, having the Steam.exe file attributes set to "Read Only", or by another program interfering with Steam's installation process (if the Steam client application has been updated to a version which was not included with your Steam installer package, Steam will download a new copy of itself and then delete the old Steam.exe file unless another program interferes).
 
1. Check your Windows user permissions.
Please ensure that you are logged in as an administrator on the machine which you are using to install Steam.
2. Check file attributes
3. Right-click on the Steam.exe file which was created after running the Steam Installer and select Properties
4. Uncheck the Read-only checkbox if it is checked and hit Apply before closing the window
5. Try running the Steam.exe file once more
6. Check your security software's settings
 
If you are running an antivirus program, firewall program, or any security product which may be interfering with the deletion and replacement of the Steam.exe file (some security software will check a file's information every time it is changed and block automatic replacement of files) please check your settings for the program and make sure that you are prompted to allow activities which may trigger the security software.
 
Remove Spyware, Adware, and Viruses and try running the installation again.
 
In addition to the above steps, perform the steps below:
1. Go to C:/Program Files/Steam/
2. Right click on Steam.exe and go to the Properties.
3. Click on the Compatibility tab.
4. Check Run as Administrator and hit okay.
5. Then I deleted StemeTemp (or something like that. has the steam icon).
6. Then run Steme.exe again.

Hope it helps.
 
Thanks and Regards,

Srinivas
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.