Starcraft Brood War: Windows Application Error - The Memory could not be read.

Here is my current specs on my computer

OS Name Microsoft® Windows Vista™ Home Premium 
Version 6.0.6001 Service Pack 1 Build 6001 
System Manufacturer Compaq-Presario 
System Model GX632AA-ABA SR5333WM 
System Type X86-based PC 
Processor AMD Athlon(tm) 64 X2 Dual Core Processor 4200+, 2200 Mhz, 2 Core(s), 2 Logical Processor(s) 
BIOS Version/Date Phoenix Technologies, LTD 5.22, 1/3/2008 
SMBIOS Version 2.4 
Installed Physical Memory (RAM) 2.00 GB 
Total Physical Memory 1.87 GB 
Available Physical Memory 785 MB 
Total Virtual Memory 3.29 GB 
Available Virtual Memory 2.12 GB 
Page File Space 1.46 GB 

As stated in the title the game is Starcraft Brood War digital version by Blizzard. The game works fine in single player mode but the problem starts when I try to connect to the game server for mulitplayer mode. Its been patched with the most recent update and all setting for compatiblity are set according to the game developers requirements. Also ports are set to be allowed through for my firewall (windows firewall, pre-installed) and current anti-virus is Norton 2010 (shutdown to play but still get error) spyware program is Ad-aware free edition that is also shutdown to play but error still happens. Anyways, once that Battlenet option is selected it will jump to the sign in screen then i get this error.

Brood War: Windows - Application Error.
The instruction at 0x760b5960 referenced memory at 0x6667677f.
The memory could not be read.

At which point the only option it allows is to close the program. All drivers have been updated for all hardware so im really at a loss on what the issue is here. Searched Developers FAQs and Support pages and Support forums to no avail. Tried un-installing an re-installing and patching countless times. Flushed my DNS and cleared temp files and even went into safemode with networking and ran it but still the same error happens. Did diskclean-up and ran memory test (passed all) defragged.

As for my Graphics card its a NVIDIA Geforce 6150 SE nForce 430, drivers up to date. Also have NVIDIA nforce 10/100 mbps Ethernet card that has been updated to most recent drivers.

Any ideals on what the problem is? If anyone can figure this out ill build an Alter in your honor and offer chickens to the computer gods daily :D
 

Question Info


Last updated December 27, 2019 Views 11,134 Applies to:
Answer
Answer
10000lakes,
    Well I would suggest that you update Windows to SP2 and all other current updates.  Since all these errors are referencing memory you may want to take out half of your memory and test the game and then switch out the memory and test. 
Mike

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.