directx_aug2009_redist and dxwebsetup failing to run on Windows 7 Ultimate

I have brought Dirt 2 and an error message "Dirt 2 cannot start because D3Dcompiler_42.dll is missing" so I am trying to install the VERY latest versions of DirectX which I believe it the August update.  I have a fresh install of Windows 7 Ultimate when when I downloaded directx_aug2009_redist extracted filed and ran DXSETUP which ended saying "an internal error occurred. Please refer to DXError.log and DirectX.log in your windos folder... the last few lines of which are:-

DorectX

12/30/09 19:02:33: dxupdate: DirectXUpdateGetSetupInformation(): Section [*** Email address is removed for privacy ***] is being installed.
12/30/09 19:02:33: dxupdate: Extracted file C:\Users\PETERW~1\AppData\Local\Temp\DX427.tmp\d3d x9_24_x64.cat from cab
12/30/09 19:02:33: dxupdate: DirectXUpdateInstallPlugIn(): SetupIterateCabinet() failed, error = 5.
12/30/09 19:02:33: dxupdate: DirectXUpdateInstallPlugIn(): Unable to iterate through C:\DirectX\Feb2005_d3dx9_24_x64.cab. The file may be damaged.
12/30/09 19:02:33: dsetup32: CSetup::InstallPlugIn(): DirectXUpdateInstallPlugIn() failed.
12/30/09 19:02:33: dsetup32: CSetup::SetupForDirectX(): InstallPlugIn() failed.
12/30/09 19:02:33: dsetup32: start finalizing: phase: 228 - 228, total: 0 - 1
12/30/09 19:02:33: DXSetup: DSetupCallback(): Phase = 3, Steps = 0
12/30/09 19:02:34: dsetup32: Installation ended with value -9 = Internal or unsupported error
12/30/09 19:03:25: DXSetup: WM_APP_ENDINSTALL
12/30/09 19:03:25: DXSetup: ~CDXWSetup()

DXError

--------------------
[12/30/09 19:02:33] module: dxupdate(Sep 4 2009), file: dxupdate.cpp, line: 5725, function: DirectXUpdateInstallPlugIn

Failed API: SetupIterateCabinet()
Error: (5) - Access is denied.

Unable to iterate through C:\DirectX\Feb2005_d3dx9_24_x64.cab. The file may be damaged.

--------------------
[12/30/09 19:02:33] module: dsetup32(Sep 4 2009), file: dxupdate.cpp, line: 280, function: CSetup::InstallPlugIn

DirectXUpdateInstallPlugIn() failed.

--------------------
[12/30/09 19:02:33] module: dsetup32(Sep 4 2009), file: setup.cpp, line: 1701, function: CSetup::SetupForDirectX

InstallPlugIn() failed.

I get a similar error when running dxwebsetup ... any help appreciated, Peter
 

Question Info


Last updated March 25, 2018 Views 2,618 Applies to:
Answer

Thanks for the replies, in the end I decided it was simpler to re-install Windows 7, then re-install the game before any other applications including the anti-virus software.  This seems to have worked - based on the all the things I tried I would agree it looks like "Real-time protection from Microsoft Security Essentials" so logging a it in Connect would be great - thanks again!

 

Regards, Peter

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Peter, I had exactly the same problem (not with Dirt2 however).

In my case, it was caused by the Real-time protection from Microsoft Security Essentials (MSE). You can temporarily disable it as follows:

- Open "Microsoft Security Essentials" application (either find it in the Win7 start menu or right-click its tray icon);
- Click on the "Settings" panel;
- In the list on the left, click on "Real-time protection";
- Clear the checkbox labeled "Turn on real-time protection (recommended)";
- Click the "Save" button at the bottom (ignore any security warnings that may come up);
- Keep the window opened, this is only temporary.

At this point, you can run your dxwebsetup (or the Aug2009 redist you already have). It should install fine.

After installation is completed, don't forget to re-enable the real-time protection in MSE! :)

Hope this helps,
Ben.

PS: I will log this as an MSE bug in Connect.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.