Can't open Games for Windows Marketplace

Hello!

I recently bought Age of Empires game from Internet store, it asked me to download Games for Windows Marketplace and run it so I can install AOE III.

I installed Games for Windows Marketplace but I can't open it, it just pops loading screen and after 5 seconds it disappears. I checked Task manager to see if the process was active, but it was not. After a little bit more trying I found out that that when the loading screen pops out, process begins to go but when it disappears, the process disappears also.

I tried to start Games for Windows Marketplace in Windows XP SP2 mode (I'm running Windows 7) but it did not help. Also, I tried to "run this program as administrator" and to disable the firewall for this program.

I haven't tried to open ports but I don't really think that this is problem with my internet connection. 

 Edit: I checked Event Viewer it showed 2 errors - 1 application error and 1 .NET Runtime error:

application error txt:

Faulting application name: GFWLClient.exe, version: 3.4.54.0, time stamp: 0x4cd50651
Faulting module name: KERNELBASE.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdaae
Exception code: 0xe0434352
Fault offset: 0x00009617
Faulting process id: 0x5cc
Faulting application start time: 0x01cb8ceafc841bff
Faulting application path: C:\Program Files\Microsoft Games for Windows - LIVE\Client\GFWLClient.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 3a7a90bf-f8de-11df-9772-0018f32c7b43
 

.NET Runtime error:

Application: GFWLClient.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException
Stack:

 

Question Info


Last updated February 11, 2019 Views 47,778 Applies to:
Answer
Answer

I have been wrestling with this problem for several hours this morning and I'm glad to report that I managed to fix this issue for me.  I think the same fix might also work for yourself as you mentioned msidcrl40.dll being problematic.

First go into %localappdata%\Microsoft\GFWLive\Logs and open up the GFWLClient01.log file (there should be one there).  Go straight to the bottom of the log file and search for a couple of lines that look a little like this:

 

  • 2010-12-16T12:52:33 Error  Startup           Failed to load library msidcrl40.dll with 0x000000C1.
  • 2010-12-16T12:52:33 Error  Startup           Failed to start. {Exception: {Type: System.BadImageFormatException} {Message: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)} {Source: XLiveServices} {Stack Trace:    at Microsoft.GamesForWindows.XLiveServices.LiveConnection.get_Instance()    at Microsoft.GamesForWindows.LiveClient.App.TryInitLiveConnection(Boolean& retry)    at Microsoft.GamesForWindows.LiveClient.App.OnStartup(StartupEventArgs e)} {Target Site: Microsoft.GamesForWindows.XLiveServices.LiveConnection get_Instance()}}
If you see these lines, this fix should work for you, but only if you have changed your default Program Files directory in the registry.  When I first installed Windows 7, I wanted to make sure I didn't use up all the space on my C: so I Google'd around to find out where in the registry this needs to be changed.  I found a site that had it on and changed the registry keys via regedit (to my D:).  However, I also changed the default location for my Program Files\Common Files (setting them to D: as well).  For me, this is the root of my problems.

You'll need to uninstall Games for Windows Marketplace from your system and also anything such as Windows Live Messanger (and anyway else that makes up the Windows Live Essentials).  Also, uninstallWindows Live Sign-on Assistant if it is installed, as it'll probably conflict.  Once you've done this, restart so to make sure none of the DLLs are being used.  Once booted back up go into Program Files and Program Files (x86) (if you have it) on each drive that it exists (C: and D: for me) and try to delete the Windows Live folder from eachCommon Files\Microsoft Shared folder.  Now are this, download CCleaner (it's free and can be found easily in Google), install it and runCleaner as well as Register->Scan for Issues and fix all issues (you may need to do the registry scan a few times as it doesn't always pick everything up).  Once you've done this, runregedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion and you should seeCommonFilesDir, CommonFilesDir (x86) (if you're running 64 bit Windows) and CommonW6432Dir.

If these are not C:\Program Files\Common Files (and C:\Program Files (x86)\Common Files if you're running 64 bit Windows) then this is your problem.  If not, then I don't think this'll help you, but you can try following the rest of the instructions regardless, it may help.

Don't worry about changing them back to C:, apparently most applications ignore this key and install to C: anyway *shrugs*.  Anyway, after changing theCommonFilesDir, CommonFilesDir (x86) and CommonW6432Dir keys back to C:, do a restart.  Next step is to install Windows Live Essentials (you'll need to install at least one of the programs in the package to get the DLL you'll need, I did Windows Live Messanger).  Once this is installed, reinstall Games for Windows Marketplace and with any luck it should be working now.

Hope this helps your issue.  I discovered this worked for me after I tried loads of other fixes that did not work.

Jargon

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.