Windows 8.1 couldn't complete update, Error 0xC1900101-0x20017

Sorry we couldn't complete the update to Windows 8.1.
We restored your previous version of Windows to this PC
0xC1900101 - 0x20017
 

Question Info


Last updated April 10, 2019 Views 28,641 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have the same issue. The preview installs in the Windows Store and then prompts me to reboot. I reboot and get a bsod (2nd time its happened) with a 0xc00000017 error code and warning about not enough ramdisk available.

I choose "boot with another operating system" and it successfully boots into Windows 8. After I login I get the message Drazen posted - the 0xC1900101-020017 error.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

The error's new to me.  Unplug any peripheral devices except mouse and keyboard

Refresh the pc

Retry

Pat
As a responsible member of the community, please mark the reply that has resolved your issue. Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have same trouble on Acer iconia W700.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm also having the problem on an iconia W700

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem several times on my Surface RT, but after removing my microSD card and then trying the install it worked. Someone already mentioned it but try removing anything connected to your device.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue here with a HP EliteBook 8570w, anything unplugged but not working.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry we couldn't complete the update to Windows 8.1.
We restored your previous version of Windows to this PC
0xC1900101 - 0x20017
The solution for me was to disable the TPM on my UEFI motherboard.  Once I did that in BIOS/UEFI setup, the Windows 8.1 Preview installed without any issues.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

4 times Kernel_Security_Check_Failure... 0xC1900101 0x30018.

Tested to unplug all devices include keyboard and mouse, but still no way to install the update! Preview failed!!!

What do you mean with TPM? Trusted Plattform Management? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

chage bios setting  "disable" secure boot ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

disabling secure boot didn't work for me

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.