Windows 8 product key activation error 0xC0000022 / 0xC004F012 & more...

Hello everyone.

I've been running Windows 8 for nearly a year now.  Genuine copy, activated, no issues whatsoever.  So after some personal issues with security, last week, I did a factory re install of my Windows 8 X64 system with high hopes.

But all I get is the Windows Activation popping up periodically, but when I try to activate Windows, error code 0XC0000022 presents itself. (SS 1).
 So tried to activate over the phone, but I did not have the Installation ID because slui 4 is bugging out too.

Ran "SLUI 3", entered product code, only to get "We couldn't verify this key, so try a different one. (SS 2)

Even tried like mentioned, SLUI 4, enter "Denmark" and Again 0XC0000022 (SS 3) and then a window with no installation ID

So after a lot of looking and researching on the internet, for a possible fix, I've gotten to try a couple of solutions without luck.

I've tried to run a recommended cmd

sfc /scannow

and this is what I get.. online or not

So I tried the next best thing I knew about "MGADiag Tool" only to be disappointed again by this screen

and that's where it suddenly became chaotic, cause now I had a new error so look up.

Apparently this problem occurs when some files in the Windows Update are missing, even though the update is downloaded and extracted successfully.

So I quickly discovered a fix recommending "Windows Update troubleshooter" Microsoft fix it" and tried it, with a actual result, for the first time since a started with this, a week ago. It looked like this

So here I through, yes! finally, and I keept going on with the recommended steps, which mentioned a "Refresh your PC without effecting your files" So I did that, only to be disappointed again 2 hours later... by (SS1) error 0xC0000022

So without any further leads, I started poking around in my control panel, just to be surprised by this too.. What, My Windows is active, but not active? huh

When clearly it states under "view activation details" "NOT AVAILABLE" one click later

and again, one click later on this page, I was tempted to look at the "Activation details" which lead me to this screenshot for you guys

Error code:


The software Licensing Service reported that the call has failed because the value for the input key was not found.

Now this is where I get really confused, because now we have 3 listed error codes.. and am honestly losing trust in all these solutions, but this one seams to be the problem.. Turns out this error shows up when something is wrong with your "Software Protection service" in Services.msc. So I checked in out, and yes truly enough..

Software protection service is not running! which I return explains with all the other services are effect, especially the Windows activation related ones. So lets start it shall we?

Access is denied?!? hmm what a surprise. Pretty much the same as the earlier error 0xC0000022. Which normally means there's wrong with my permissions, since access shouldn't be denied.. So I went to the next logical place.. Propertice to check the permissions, and yes truly enough, everything is grayed out like this

aha I through and I quickly found myself the sppsvc.exe file in my Windows dic. and changed all the permissions to FULL CONTROL. Only to get back to the exact same restricted screens.

Now here I am a week later with a lot of knowledge, but no real result.. really confused and bothered.. So ye, I really hope someone out there is smart enough to come up with a proper fix for this.



Ok, I usually don't reply and attempt to help but since I spent so much time researching this issue after experiencing the very same issue here it goes:

This solution worked for me on Windows 7 it has not been tested on Windows 8 but it worked for me after I tried all of the same steps as the original poster to no avail.

The problem is the Software Protection service and it's inability to start as you found early on.

Step 1. Open an administrative command prompt.

Step 2. Copy and paste the following command into your command prompt and hit enter. This resets the permissions on the service correctly:

icacls %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform /grant "BUILTIN\Administrators:(OI)(CI)(F)" "NT AUTHORITY\SYSTEM:(OI)(CI)(F)" "NT Service\sppsvc:(OI)(CI)(R,W,D)" "NETWORK SERVICE:(OI)(CI)(F)" 

Step 3. Open Windows Explorer and navigate to %windir%\System32

Step 4. Make sure that you can see hidden and system files and folders.

Step 5. Delete any Files/Folders with the following name (You can move them to an archive folder instead of deleting them if you want to be safe):


Step 6. In your Windows Explorer window navigate to:


Step 7. Rename tokens.dat to tokens.bak

Step 8. Try to start the Software Protection service. It should start successfully now. If it does then restart the computer and try activating Windows again.

Thank You to Craig Garland and   Santosh Bhandarkar for their posts on Technet about the Software Protection service which lead me to this answer. 


12 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated July 5, 2020 Views 12,434 Applies to: