Question

Q: .net framework 3.5 hangs when attempting to turn it on in windows features

I've upgraded from Windows 7 Pro 64 bit to Windows 8 Pro.  a dialogue box popped up towards the end of the install stating "an app on your PC needs the following Windows feature .NET Framework 3.5 (includes 2.0 and 3.0)"  Clicking install this feature another dialogue box pops up stating it is searching for required files.  I've let it run for hours on end and it just hangs there with a little green bar continuously traversing the dialogue box.  I had to kill it. I could not x out of it or use the cancel button.  It would not close.  I've rebooted several times.  I've tried to turn the feature on from Control Panel/Programs/Programs and Features and the same scenario happens.  I end up with the dialogue box just sitting there looking like it is searching for the required files but I think it is actually lost in never never land.  help please.


Hi,
 
Welcome to the Microsoft community!!!
 
Just a few question to understand the issue better,
 
  • What happens when you restart the computer?
  • Does the message popup automatically after you login?
 
Windows 8 comes with inbuilt .NET framework 4.5, but some applications might need .NET framework 3.5 to run. I would suggest you to check out the following steps to see if it helps,
 
Method 1:

Check if .NET framework 3.5 is enabled as described in ‘Enabling the .NET framework 3.5 in control panel’ in the below link;
 
If you couldn’t enable it, try the troubleshooting steps provided in the above link. If you couldn’t find .NET framework already installed in your computer, you can also download and install the .NET framework from the Microsoft website. I have provided below the link to download .NET framework 3.5.
 
Method 2:
 
a) Press Windows key + X, select ‘System’
b) Click on ‘Windows update’ on the bottom of the left panel
c) In Windows update, check if any new updates are available and install.
 

 
Hope this helps. If the problem remains unresolved, please get back to us and we would be happy to help you further.
Cheers,
Ben.

Did this solve your problem?

Sorry this didn't help.

90 people were helped by this reply


Hi, 

I followed all your instructions.

I even downloaded a 231MB full setup of .net framework 3.5.

Funny thing is even while trying to install this setup too its showing same window that "this pc needs one of the following feature (which is .net 3.5) to install this program."

I even tried mounting the windows 8 iso and tried to install .net 3.5 feature using the DISM command but that too shows some error.

I tried to repair the DISM image thinking that its corrupt, but its not.

I have tried every single thing that could google up. It simply doesnt work.

Please help....!!!

I am in desperate need of it....!

Waiting eagerly for your reply...

Thank You

Did this solve your problem?

Sorry this didn't help.

4 people were helped by this reply


Hi, 

I followed all your instructions.

I even downloaded a 231MB full setup of .net framework 3.5.

Funny thing is even while trying to install this setup too its showing same window that "this pc needs one of the following feature (which is .net 3.5) to install this program."

I even tried mounting the windows 8 iso and tried to install .net 3.5 feature using the DISM command but that too shows some error.

I tried to repair the DISM image thinking that its corrupt, but its not.

I have tried every single thing that could google up. It simply doesnt work.

Please help....!!!

I am in desperate need of it....!

Waiting eagerly for your reply...

Thank You

Try copying the entire sources directory to your C drive. 
You're also missing a few flags.  Try this (EXACTLY AS WRITTEN - if you copied your Sources folder to your C drive):

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:c:\sources\sxs

That's my usual build strategy for remote systems and tends to solve these little issues for good.

Hope this helps!

Have a happy 4th!

Did this solve your problem?

Sorry this didn't help.

13 people were helped by this reply


this command

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:c:\sources\sxs

worked after copying into c:\sources\sxs

same thing was not working from CD drive

thanks

Did this solve your problem?

Sorry this didn't help.


Hi, 

I followed all your instructions.

I even downloaded a 231MB full setup of .net framework 3.5.

Funny thing is even while trying to install this setup too its showing same window that "this pc needs one of the following feature (which is .net 3.5) to install this program."

I even tried mounting the windows 8 iso and tried to install .net 3.5 feature using the DISM command but that too shows some error.

I tried to repair the DISM image thinking that its corrupt, but its not.

I have tried every single thing that could google up. It simply doesnt work.

Please help....!!!

I am in desperate need of it....!

Waiting eagerly for your reply...

Thank You

Try copying the entire sources directory to your C drive. 
You're also missing a few flags.  Try this (EXACTLY AS WRITTEN - if you copied your Sources folder to your C drive):

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:c:\sources\sxs

That's my usual build strategy for remote systems and tends to solve these little issues for good.

Hope this helps!

Have a happy 4th!

I tried this but it just hangs on the cmd prompt after Image Version, if  I do it from disck or from the c: drive

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


Hi all,

I followed all the instructions on the internet but nothing worked for me.

I finaly got it working by installing all the micrsoft update's.

Afhter this I enabled it, and it works.

Hoppefully peaple get it working, I spend 2 days on it.

Did this solve your problem?

Sorry this didn't help.


I was about to try this on a Surface Pro 4 but decided to wait, It took about 45 mins hanging at "Downloading required Files" with the progress bar at full. Then it finished it's install. FYI for anyone trying this it might be an idea to do it and just wait. Office 365 does the same thing on install - Just hangs for ages with no progress showing.

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


I've upgraded from Windows 7 Pro 64 bit to Windows 8 Pro.  a dialogue box popped up towards the end of the install stating "an app on your PC needs the following Windows feature .NET Framework 3.5 (includes 2.0 and 3.0)"  Clicking install this feature another dialogue box pops up stating it is searching for required files.  I've let it run for hours on end and it just hangs there with a little green bar continuously traversing the dialogue box.  I had to kill it. I could not x out of it or use the cancel button.  It would not close.  I've rebooted several times.  I've tried to turn the feature on from Control Panel/Programs/Programs and Features and the same scenario happens.  I end up with the dialogue box just sitting there looking like it is searching for the required files but I think it is actually lost in never never land.  help please.

This worked for me

1. check windows update is on

2. check windows update service is enabled run services.exe

You can try:

  1. Delete everything under: C:\Windows\SoftwareDistribution\Download
    Those are left over from Windows Updates and no longer needed.
  2. From Admin Command prompt, run:
    Dism /Online /Cleanup-Image /StartComponentCleanup
  3. Turn on Net Framework 3.5 from programs & Features again to see if it helps.


FYI, This problem has been going on in the previous versions of Windows. That's why I mentioned this in Windows 8 Forums that you should turn on Net Framework 3.5 right after Windows Installation to avoid conflict with third party softwares. It works every single time for me.

Did this solve your problem?

Sorry this didn't help.

15 people were helped by this reply


 
Question Info

Views: 37,931 Last updated: July 17, 2018 Applies to: