Windows Update Error Code 80244019

Hi, I'm using Windows 8 (not 8.1) on an Acer Aspire V3-571 laptop. I get my internet via the phone line with a TP-Link ADSL modem and wifi-router. I use wifi all the time. For a year and a half since I bought this laptop everything has been fine. I keep my computer clean with Windows Defender, Spybot and Malwarebytes Free. I update them almost every day and run full scans once a week. I haven't had a virus for ages.

But now over the last week or so I get Error Code 80244019 if I try to do Windows Update. I've tried switching off the wifi and using a LAN cable from the router to the laptop, but it's just the same.

But here's the odd thing. I've tried switching off the modem entirely, and, instead, using a plug-in USB modem with a mobile phone SIM card inside charged up with an internet account, and Windows Update works! No problem.

So, Windows Update doesn't like my ADSL modem suddenly after one and a half years of being OK, but, it does like my plug-in USB mobile phone system modem!

I've tried resetting the ADSL modem back to its original factory settings and starting again, but it's still no good. I get the same error code.

Can anyone help?

Thanks!
 

Question Info


Last updated May 25, 2019 Views 736,959 Applies to:
Answer
Answer

Hi,

Thannk you for replying with the status of the issue.

First of all I would like to apologize for incomplete steps.

I would suggest you to try the following steps to turn on Data Execution Prevention.

Follow the steps to turn on Data Execution Protection:

a. Click on This PC and right click on free space and click Properties.

b. Click on the Advanced system settings and then click on Advanced tab.

c. Click on Settings under Performance.

d. Click on Data Execution Prevention.

e. Click on Turn on DEP for Essential Windows Programs and Services only.

i. Click on Apply. Click on OK twice. 

j. Restart computer and check.

Also try Method 2 and once you are done with the troubleshooting steps reply with the status of the issue.

We will be happy t assist you anytime.

Basith M
- Forum Moderator (Multiple Forums)

372 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

I solved this issue by checking out which update it stumbled on (check out update history). In my case it was "KB907417: Update voor Office 2003".

I downloaded the update and manually installed it. Then I rebooted the laptop (Dell Latitude). After that the problem was solved.

https://www.microsoft.com/nl-nl/download/details.aspx?id=10624

Best regards,

Michiel

274 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.