.Net Framework 3.5 fails to install with error code 0x800F081F

Original Title: Error installing .net framework 3.5 sp1

 

I did a refresh of my install of windows 8 pro (64 bit), because Weather and several other apps were failing (they started, then the main window closed, but the small window stayed in the task list to the left; event viewer gave access permissions errors).

 

This seemed to sort most of the apps BUT now I cannot re-install many programs as they need .net framework 3.5 and this fails to install with error 0x800F081F. I even tried downloading the full installer and running locally but it still gives the same error!

 

I need the framework to work with OpenXML development, a large part of my work.

 

(I should also point out the refresh says most apps are retained - it fails to mention all applications are removed!)

 

 

Question Info


Last updated December 8, 2018 Views 219,285 Applies to:
Answer

Hi Andy,

 

Thank you for posting your query in Microsoft Community and giving us an opportunity to assist you.

 

From the issue description, you are facing issues with installing .Net Framework 3.5 and receiving error code 0x800F081F.

 

There is a Microsoft Knowledge Base article that provides methods to troubleshoot this issue. I would suggest that you visit the link and use the methods to resolve the issue.

 

Error codes when you try to install the .NET Framework 3.5 in Windows 8 or in Windows Server 2012

http://support.microsoft.com/kb/2734782

 

You may also refer this link for more information:

 

Installing the .NET Framework 3.5 on Windows 8

http://msdn.microsoft.com/en-us/library/hh506443.aspx

 

Hope this information helps. Let us know if you need any further assistance related to Windows.

154 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.