My eGalax USB touchscreen no longer works with Win8

Hi it used to work and still works on my Ubuntu system.

I have tried everything - asked manufacturer for Win8 drivers (no joy) , asked Microsoft for Win8 drivers , no joy

It still recognises the "touch" but it is mostly out by 2cms to the right & 1 cm up,but this is wholey inconsistant!

I have tried re-calibration via control panel but the 1st cross hair sits in the top left hand corner but won't move on as it used to do under Win7

Why? Should there be a new version of tabcal.exe for Win8? or has something changed which means touchscreen is only available to tablets now (i.e the Win8 RT version) If so that is a very poor show

Touch screen technology is made for Win8, I am deeply disappointed, does anyone have the same issue or any help which can get my screen back and working again?

Many thanks in anticipation

Keef 

 

Question Info


Last updated November 21, 2019 Views 4,895 Applies to:
Answer
Answer

Hello KeefHellinger,

 

Thank you for asking the Question!

 

Sorry to know that you face issues with eGalax USB touchscreen  . As I get it right the eGalax USB touchscreen does not work properly.

 

Download and Install the Windows 7 driver in compatibility mode and check.

http://home.eeti.com.tw/web20/eGalaxTouchDriver/W7Driver.htm

 

 

Run the Driver in Windows 7 compatibility mode and see if it helps.

a: Right Click on the setup file and select Properties.

b: Now click the compatibility tab .

c: Place a check mark on the option “ Run this program in compatibility mode for

d: Select Windows 7.

 

Reply to us if you face any issues with eGalax USB touchscreen    or any other Windows Issue, and I would be glad to assist you again and try to rectify the issue as early as possible.

 

Have a nice day!

 

Hope this information helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.